summaryrefslogtreecommitdiff
path: root/package/python-serial
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-12-11 21:26:51 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-12-15 13:38:57 +0100
commit5da217204c5d499541237aa54056d32ab0ed5c95 (patch)
tree2fc21aa9b20675c9e9412d7ba4106748db9a0284 /package/python-serial
parent3485afbce67de30ea486357971e2afae9555ee28 (diff)
python-serial: convert to the Python package infrastructure
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python-serial')
-rw-r--r--package/python-serial/python-serial.mk13
1 files changed, 2 insertions, 11 deletions
diff --git a/package/python-serial/python-serial.mk b/package/python-serial/python-serial.mk
index e00577ba1..a44d79902 100644
--- a/package/python-serial/python-serial.mk
+++ b/package/python-serial/python-serial.mk
@@ -7,15 +7,6 @@
PYTHON_SERIAL_VERSION = 2.6
PYTHON_SERIAL_SOURCE = pyserial-$(PYTHON_SERIAL_VERSION).tar.gz
PYTHON_SERIAL_SITE = http://pypi.python.org/packages/source/p/pyserial
+PYTHON_SERIAL_SETUP_TYPE = distutils
-PYTHON_SERIAL_DEPENDENCIES = python
-
-define PYTHON_SERIAL_BUILD_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py build --executable=/usr/bin/python)
-endef
-
-define PYTHON_SERIAL_INSTALL_TARGET_CMDS
- (cd $(@D); $(HOST_DIR)/usr/bin/python setup.py install --prefix=$(TARGET_DIR)/usr)
-endef
-
-$(eval $(generic-package))
+$(eval $(python-package))