summaryrefslogtreecommitdiff
path: root/package/python-setuptools
diff options
context:
space:
mode:
authorMarkos Chandras <markos.chandras@imgtec.com>2013-08-22 21:52:57 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-08-27 22:32:55 +0200
commit0b363ba5f389b3744937658f40f1e796e5447db3 (patch)
treedd80fa05cbad06faa3ce66b166e493ef9ebc6be0 /package/python-setuptools
parent5871b791995ebe295db7dca608afe3f293ce8953 (diff)
python-setuptools: Add missing $(TARGET_DIR) to PYTHONPATH
The $(TARGET_DIR) variable is required when building python-setuptools for the target otherwise the build system detects the host installation which leads to permission error problems like these: Setuptools installation detected at /usr/lib64/python2.7/site-packages Renaming /usr/lib64/python2.7/site-packages/setuptools-0.9.8-py2.7.egg-info to /usr/lib64/python2.7/site-packages/setuptools-0.9.8-py2.7.egg-info.OLD.1377005697.88 OSError: [Errno 13] Permission denied Moreover, remove the PYTHONPATH variable for host variant since it's not needed. Signed-off-by: Markos Chandras <markos.chandras@imgtec.com> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python-setuptools')
-rw-r--r--package/python-setuptools/python-setuptools.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/python-setuptools/python-setuptools.mk b/package/python-setuptools/python-setuptools.mk
index cd5ee4d04..73c819f27 100644
--- a/package/python-setuptools/python-setuptools.mk
+++ b/package/python-setuptools/python-setuptools.mk
@@ -20,19 +20,18 @@ endef
define PYTHON_SETUPTOOLS_BUILD_CMDS
(cd $(@D); \
- PYTHONPATH="/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
+ PYTHONPATH="$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
$(HOST_DIR)/usr/bin/python setup.py build)
endef
define HOST_PYTHON_SETUPTOOLS_INSTALL_CMDS
(cd $(@D); \
- PYTHONPATH="$(HOST_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
$(HOST_DIR)/usr/bin/python setup.py install --prefix=$(HOST_DIR)/usr)
endef
define PYTHON_SETUPTOOLS_INSTALL_TARGET_CMDS
(cd $(@D); \
- PYTHONPATH="/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
+ PYTHONPATH="$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
$(HOST_DIR)/usr/bin/python setup.py install --executable=/usr/bin/python \
--single-version-externally-managed --root=/ --prefix=$(TARGET_DIR)/usr)
endef