summaryrefslogtreecommitdiff
path: root/package/python-slob
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-10-09 14:46:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-09 23:04:44 +0200
commit4eaf9b248f9af6df9d511efd85abfd101db44145 (patch)
tree7a8e9ffd5e54edcf85fe765718447759ae698d4a /package/python-slob
parent49b7a57d351719ee0148f21b5a807836de59c934 (diff)
package/python-slob: new package
Needed for the upcoming python-mwscrape2slob package. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-slob')
-rw-r--r--package/python-slob/Config.in17
-rw-r--r--package/python-slob/python-slob.hash2
-rw-r--r--package/python-slob/python-slob.mk13
3 files changed, 32 insertions, 0 deletions
diff --git a/package/python-slob/Config.in b/package/python-slob/Config.in
new file mode 100644
index 000000000..2c8ddb088
--- /dev/null
+++ b/package/python-slob/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_PYTHON_SLOB
+ bool "python-slob"
+ depends on !BR2_BINFMT_FLAT # python-pyicu -> icu
+ depends on BR2_INSTALL_LIBSTDCPP # python-pyicu -> icu
+ depends on BR2_PACKAGE_PYTHON3
+ select BR2_PACKAGE_PYTHON_PYICU # runtime
+ # although optional, it is used as default compression
+ select BR2_PACKAGE_PYTHON3_XZ # runtime
+ help
+ slob.py is a reference implementation of slob format reader
+ and writer.
+
+ https://github.com/itkach/slob
+
+comment "python-slob needs a toolchain w/ C++"
+ depends on BR2_PACKAGE_PYTHON3 && !BR2_BINFMT_FLAT
+ depends on !BR2_INSTALL_LIBSTDCPP
diff --git a/package/python-slob/python-slob.hash b/package/python-slob/python-slob.hash
new file mode 100644
index 000000000..39d5d81f3
--- /dev/null
+++ b/package/python-slob/python-slob.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 18eb4f45d09d49b1f776cac52ea70ab951566c60cd30bbec39e88f10908fd8ff python-slob-31ad0e769360a5b10a4893f686587bb8e48c3895.tar.gz
diff --git a/package/python-slob/python-slob.mk b/package/python-slob/python-slob.mk
new file mode 100644
index 000000000..474c0c94d
--- /dev/null
+++ b/package/python-slob/python-slob.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-slob
+#
+################################################################################
+
+PYTHON_SLOB_VERSION = 31ad0e769360a5b10a4893f686587bb8e48c3895
+PYTHON_SLOB_SITE = $(call github,itkach,slob,$(PYTHON_SLOB_VERSION))
+PYTHON_SLOB_LICENSE = GPLv3
+PYTHON_SLOB_LICENSE_FILES = LICENSE
+PYTHON_SLOB_SETUP_TYPE = distutils
+
+$(eval $(python-package))