summaryrefslogtreecommitdiff
path: root/package/python-tomako
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-06-30 09:55:04 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-01 15:27:26 +0200
commit1a4f44802baf4cbb34c674e167dda6029df9282f (patch)
tree154107993828ef8ccfd1fe5df228520a0e24e6d4 /package/python-tomako
parentc37648bac43344750bdff130cb3cda97fa9152f5 (diff)
python-tomako: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-tomako')
-rw-r--r--package/python-tomako/Config.in9
-rw-r--r--package/python-tomako/python-tomako.hash4
-rw-r--r--package/python-tomako/python-tomako.mk13
3 files changed, 26 insertions, 0 deletions
diff --git a/package/python-tomako/Config.in b/package/python-tomako/Config.in
new file mode 100644
index 000000000..bd6d29982
--- /dev/null
+++ b/package/python-tomako/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_TOMAKO
+ bool "python-tomako"
+ select BR2_PACKAGE_PYTHON_TORNADO # runtime
+ select BR2_PACKAGE_PYTHON_MAKO # runtime
+ help
+ Tomako is the easiest way to use Mako as a template engine for
+ Tornado.
+
+ https://github.com/rcmachado/tomako
diff --git a/package/python-tomako/python-tomako.hash b/package/python-tomako/python-tomako.hash
new file mode 100644
index 000000000..678944ad6
--- /dev/null
+++ b/package/python-tomako/python-tomako.hash
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/tomako/json
+md5 74597762d156f52b8716aced94d51f2a tomako-0.1.0.tar.gz
+# sha256 calculated by scanpypi
+sha256 e541e6bad009d3f61956b135757d491bf42c97cb441e7c11ef7a0ef6e9460a9f tomako-0.1.0.tar.gz
diff --git a/package/python-tomako/python-tomako.mk b/package/python-tomako/python-tomako.mk
new file mode 100644
index 000000000..a9eef6405
--- /dev/null
+++ b/package/python-tomako/python-tomako.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-tomako
+#
+################################################################################
+
+PYTHON_TOMAKO_VERSION = 0.1.0
+PYTHON_TOMAKO_SOURCE = tomako-$(PYTHON_TOMAKO_VERSION).tar.gz
+PYTHON_TOMAKO_SITE = https://pypi.python.org/packages/66/6f/de5449d401ca6953691c765d7465941e772cf99a3547646edc58cdca452d
+PYTHON_TOMAKO_SETUP_TYPE = setuptools
+PYTHON_TOMAKO_LICENSE = MIT
+
+$(eval $(python-package))