summaryrefslogtreecommitdiff
path: root/package/python-xlwt
diff options
context:
space:
mode:
authorYegor Yefremov <yegorslists@googlemail.com>2016-06-29 08:27:04 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-01 17:31:02 +0200
commitabf0cd28710c0cfecaf59c852f4e49708956a231 (patch)
tree5db13c31febac30c2214b12719ff3e7e8406290f /package/python-xlwt
parent0a694c548dfed94239dc82cc6f4398ea24c32cc5 (diff)
python-xlwt: new package
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python-xlwt')
-rw-r--r--package/python-xlwt/Config.in8
-rw-r--r--package/python-xlwt/python-xlwt.hash4
-rw-r--r--package/python-xlwt/python-xlwt.mk14
3 files changed, 26 insertions, 0 deletions
diff --git a/package/python-xlwt/Config.in b/package/python-xlwt/Config.in
new file mode 100644
index 000000000..a48ac6fb7
--- /dev/null
+++ b/package/python-xlwt/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_XLWT
+ bool "python-xlwt"
+ help
+ Library to create spreadsheet files compatible with MS Excel
+ 97/2000/XP/2003 XLS files, on any platform, with Python 2.6,
+ 2.7, 3.3+.
+
+ http://www.python-excel.org/
diff --git a/package/python-xlwt/python-xlwt.hash b/package/python-xlwt/python-xlwt.hash
new file mode 100644
index 000000000..4cacf2b49
--- /dev/null
+++ b/package/python-xlwt/python-xlwt.hash
@@ -0,0 +1,4 @@
+# md5 from https://pypi.python.org/pypi/xlwt/json
+md5 fadf8d1be8c5f071561c4145ed5f5b89 xlwt-1.1.2.tar.gz
+# sha256 calculated by scanpypi
+sha256 aed648c17731f40f84550dd2a1aaa53569f0cbcaf5610ba895cd2632587b723c xlwt-1.1.2.tar.gz
diff --git a/package/python-xlwt/python-xlwt.mk b/package/python-xlwt/python-xlwt.mk
new file mode 100644
index 000000000..38d5f09d3
--- /dev/null
+++ b/package/python-xlwt/python-xlwt.mk
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-xlwt
+#
+################################################################################
+
+PYTHON_XLWT_VERSION = 1.1.2
+PYTHON_XLWT_SOURCE = xlwt-$(PYTHON_XLWT_VERSION).tar.gz
+PYTHON_XLWT_SITE = https://pypi.python.org/packages/0b/69/644313df86e6375ec2c6b34ec8ac544b9cc7803b7d943223d32811860f3d
+PYTHON_XLWT_SETUP_TYPE = setuptools
+PYTHON_XLWT_LICENSE = BSD-3c, BSD-4c
+PYTHON_XLWT_LICENSE_FILES = docs/licenses.rst
+
+$(eval $(python-package))