summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorSamuel Martin <s.martin49@gmail.com>2014-04-06 09:35:15 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-04-06 11:55:26 +0200
commit2ffcd79cd26376931434ce76597e9db3d3f77db7 (patch)
treeda74679f886abf9319c514215dd0571e49b48135 /package/python
parent00f4e0331ea63568450874756375586bcd122cf4 (diff)
python: fix host-python symlink installation when no python is selected
When no python interpreter is selected, all host-python symlink installation were disabled. This could lead to a non-existing $(HOST_DIR)/usr/bin/python program. Fixes: http://autobuild.buildroot.net/results/6e7/6e74a343b4e8e113fd34d45c9279419e233afe8a/ Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index feff64411..8a2ba6516 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -192,9 +192,9 @@ PYTHON_POST_INSTALL_STAGING_HOOKS += PYTHON_INSTALL_STAGING_PYTHON_CONFIG_SYMLIN
PYTHON_AUTORECONF = YES
# Some packages may have build scripts requiring python2.
-# Only install the python symlink in the host tree if python2 is enabled
-# for the target.
-ifeq ($(BR2_PACKAGE_PYTHON),y)
+# Only install the python symlink in the host tree if python3 is not enabled
+# for the target, otherwise the default python program may be missing.
+ifneq ($(BR2_PACKAGE_PYTHON3),y)
define HOST_PYTHON_INSTALL_PYTHON_SYMLINK
ln -sf python2 $(HOST_DIR)/usr/bin/python
ln -sf python2-config $(HOST_DIR)/usr/bin/python-config