summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorPrzemyslaw Wrzos <przemyslaw.wrzos@calyptech.com>2014-02-18 21:40:07 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-19 08:53:59 +0100
commit99d930e65db24ac1ed5e768324154cc1f10e9eae (patch)
treeba6ff06743b4a818c7e81d42d8d51152b0e6d288 /package/python
parente51f87b825819986613cff58038b797e9925b25d (diff)
python, python3: fix to ensure libpython is stripped
The python and python3 builds mark libpython as read-only which prevents it from being stripped out correctly for the target. Signed-off-by: Przemyslaw Wrzos <przemyslaw.wrzos@calyptech.com> Acked-by: Thomas De Schampheleire <thomas.de_schampheleire@alcatel-lucent.com> Tested-by: Thomas De Schampheleire <thomas.de_schampheleire@alcatel-lucent.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 3b0a4ddfd..94765cbb8 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -160,6 +160,15 @@ endef
PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_USELESS_FILES
+#
+# Make sure libpython gets stripped out on target
+#
+define PYTHON_ENSURE_LIBPYTHON_STRIPPED
+ chmod u+w $(TARGET_DIR)/usr/lib/libpython$(PYTHON_VERSION_MAJOR)*.so
+endef
+
+PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_ENSURE_LIBPYTHON_STRIPPED
+
PYTHON_AUTORECONF = YES
# Provided to other packages