summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 16:19:26 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 16:19:26 +0100
commit9b79f2a637f6fa9a42ebabc6605ff3bbed792e47 (patch)
treea7ec9c606f1ea0d5c1fa9b1bdff4d6c0b65cbf49 /package/python
parent9c335f1838ec368840ca8292eb3b6c23b5f9907d (diff)
python: add an option to make the ossaudiodev module optional for the target
Now that we have a configure option in Python to enable/disable the ossaudiodev module, this commit adds a configuration option to the target Python to explicitly enable/disable this module. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/Config.in5
-rw-r--r--package/python/python.mk6
2 files changed, 11 insertions, 0 deletions
diff --git a/package/python/Config.in b/package/python/Config.in
index 8b27630d7..87defad81 100644
--- a/package/python/Config.in
+++ b/package/python/Config.in
@@ -60,6 +60,11 @@ config BR2_PACKAGE_PYTHON_CURSES
help
curses module for Python.
+config BR2_PACKAGE_PYTHON_OSSAUDIODEV
+ bool "ossaudiodev module"
+ help
+ ossaudiodev module for Python.
+
config BR2_PACKAGE_PYTHON_PYEXPAT
select BR2_PACKAGE_EXPAT
bool "pyexpat"
diff --git a/package/python/python.mk b/package/python/python.mk
index bf063e950..4a3e71c8a 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -120,6 +120,12 @@ ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
PYTHON_DEPENDENCIES += openssl
endif
+ifeq ($(BR2_PACKAGE_PYTHON_OSSAUDIODEV),y)
+PYTHON_CONF_OPTS += --enable-ossaudiodev
+else
+PYTHON_CONF_OPTS += --disable-ossaudiodev
+endif
+
PYTHON_CONF_ENV += \
ac_cv_have_long_long_format=yes \
ac_cv_file__dev_ptmx=yes \