summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorHenry Margies <henry.margies@gmail.com>2014-07-09 11:38:59 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-07-15 20:39:09 +0200
commita37b214c434d92dd7be3ddd69ca3c669c954c3a9 (patch)
tree04c81e4903f00fd84fc30c2704a5eb7a0dab8976 /package/python
parent9aaf13c91c16b520ac8a4c4d1f94296f56ee13f8 (diff)
python, python3: build with tzset support
This patch adds support for time.tzset() in Python 2.7 and Python 3. The Python configure script sets ac_cv_working_tzset to 'no' when cross compiling, although it should be available and work with all toolchains supported by Buildroot (?). The patch below pre-sets the variable so that time.tzset() works. [Thomas: adjust commit log.] Signed-off-by: Henry Margies <henry.margies@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index cb54e3e96..b23784867 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -121,7 +121,8 @@ endif
PYTHON_CONF_ENV += \
ac_cv_have_long_long_format=yes \
ac_cv_file__dev_ptmx=yes \
- ac_cv_file__dev_ptc=yes
+ ac_cv_file__dev_ptc=yes \
+ ac_cv_working_tzset=yes
PYTHON_CONF_OPT += \
--without-cxx-main \