summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/python
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk26
1 files changed, 13 insertions, 13 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index b23784867..f9968ca89 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -16,7 +16,7 @@ PYTHON_LICENSE_FILES = LICENSE
# also installed in $(HOST_DIR), as it is needed when cross-compiling
# third-party Python modules.
-HOST_PYTHON_CONF_OPT += \
+HOST_PYTHON_CONF_OPTS += \
--enable-static \
--without-cxx-main \
--disable-sqlite3 \
@@ -61,57 +61,57 @@ endif
ifeq ($(BR2_PACKAGE_PYTHON_CURSES),y)
PYTHON_DEPENDENCIES += ncurses
else
-PYTHON_CONF_OPT += --disable-curses
+PYTHON_CONF_OPTS += --disable-curses
endif
ifeq ($(BR2_PACKAGE_PYTHON_PYEXPAT),y)
PYTHON_DEPENDENCIES += expat
-PYTHON_CONF_OPT += --with-expat=system
+PYTHON_CONF_OPTS += --with-expat=system
else
-PYTHON_CONF_OPT += --with-expat=none
+PYTHON_CONF_OPTS += --with-expat=none
endif
ifeq ($(BR2_PACKAGE_PYTHON_BSDDB),y)
PYTHON_DEPENDENCIES += berkeleydb
else
-PYTHON_CONF_OPT += --disable-bsddb
+PYTHON_CONF_OPTS += --disable-bsddb
endif
ifeq ($(BR2_PACKAGE_PYTHON_SQLITE),y)
PYTHON_DEPENDENCIES += sqlite
else
-PYTHON_CONF_OPT += --disable-sqlite3
+PYTHON_CONF_OPTS += --disable-sqlite3
endif
ifeq ($(BR2_PACKAGE_PYTHON_SSL),y)
PYTHON_DEPENDENCIES += openssl
else
-PYTHON_CONF_OPT += --disable-ssl
+PYTHON_CONF_OPTS += --disable-ssl
endif
ifneq ($(BR2_PACKAGE_PYTHON_CODECSCJK),y)
-PYTHON_CONF_OPT += --disable-codecs-cjk
+PYTHON_CONF_OPTS += --disable-codecs-cjk
endif
ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
-PYTHON_CONF_OPT += --disable-unicodedata
+PYTHON_CONF_OPTS += --disable-unicodedata
endif
# Default is UCS2 w/o a conf opt
ifeq ($(BR2_PACKAGE_PYTHON_UCS4),y)
-PYTHON_CONF_OPT += --enable-unicode=ucs4
+PYTHON_CONF_OPTS += --enable-unicode=ucs4
endif
ifeq ($(BR2_PACKAGE_PYTHON_BZIP2),y)
PYTHON_DEPENDENCIES += bzip2
else
-PYTHON_CONF_OPT += --disable-bz2
+PYTHON_CONF_OPTS += --disable-bz2
endif
ifeq ($(BR2_PACKAGE_PYTHON_ZLIB),y)
PYTHON_DEPENDENCIES += zlib
else
-PYTHON_CONF_OPT += --disable-zlib
+PYTHON_CONF_OPTS += --disable-zlib
endif
ifeq ($(BR2_PACKAGE_PYTHON_HASHLIB),y)
@@ -124,7 +124,7 @@ PYTHON_CONF_ENV += \
ac_cv_file__dev_ptc=yes \
ac_cv_working_tzset=yes
-PYTHON_CONF_OPT += \
+PYTHON_CONF_OPTS += \
--without-cxx-main \
--without-doc-strings \
--with-system-ffi \