summaryrefslogtreecommitdiff
path: root/package/python
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-02-07 11:16:05 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-02-18 23:09:05 +0100
commitc3d539b53ff0533e91ae849dbdcdd589b0fec0cc (patch)
treef96ffe3bce3229417b4c2fba06b8504a69b7a8d0 /package/python
parenta423ec1519dca2ee7e154c483b6b441c928b292e (diff)
host python/python3: conditionally disable unicodedata
The host python always had --disable-unicodedata, regardless of the corresponding configuration option BR2_PACKAGE_PYTHON_UNICODEDATA. Since the host python is used to byte-compile python modules, this meant that such modules could not contain unicode strings. For example, following statement in a python module: print u"\N{SOLIDUS}" would cause the byte-compilation to fail with message: SyntaxError: ("(unicode error) \\N escapes not supported (can't load unicodedata module)", Instead, conditionally disable unicodedata based on BR2_PACKAGE_PYTHON_UNICODEDATA, also for the host python. This fixes bug #6542 (https://bugs.busybox.net/show_bug.cgi?id=6542) Reported-by: Gernot Vormayr <gvormayr@gmail.com> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/python')
-rw-r--r--package/python/python.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/python/python.mk b/package/python/python.mk
index 6187d66e7..163e6f579 100644
--- a/package/python/python.mk
+++ b/package/python/python.mk
@@ -26,7 +26,6 @@ HOST_PYTHON_CONF_OPT += \
--disable-curses \
--disable-codecs-cjk \
--disable-nis \
- --disable-unicodedata \
--disable-dbm \
--disable-gdbm \
--disable-bsddb \
@@ -100,6 +99,7 @@ endif
ifneq ($(BR2_PACKAGE_PYTHON_UNICODEDATA),y)
PYTHON_CONF_OPT += --disable-unicodedata
+HOST_PYTHON_CONF_OPT += --disable-unicodedata
endif
# Default is UCS2 w/o a conf opt