summaryrefslogtreecommitdiff
path: root/package/qemu
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-09-08 20:46:58 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-08 22:13:18 +0200
commit524b6b85595274ca13bd7d01adb61ce2dddd786c (patch)
tree2f3c2cf3006adb0fb11db320b02ca66d923bbc0a /package/qemu
parent031659024b3cf27bb68dc58d07519b563ef472a1 (diff)
package/qemu: fix build of host variant
The Qemu buildsystem expects that the cpp it is passed can be called like it were cc: it passes it the '-c' option, which is not allowed by cpp, but is allowed for cc. Fix that by overriding CPP when calling configure. Note: the target variant of Qemu does not build the affected parts (the PC-BIOS images). This is another problem that should be fixed separately. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qemu')
-rw-r--r--package/qemu/qemu.mk21
1 files changed, 12 insertions, 9 deletions
diff --git a/package/qemu/qemu.mk b/package/qemu/qemu.mk
index 42dd9c299..9815f76cf 100644
--- a/package/qemu/qemu.mk
+++ b/package/qemu/qemu.mk
@@ -110,16 +110,19 @@ HOST_QEMU_OPTS += --enable-vde
HOST_QEMU_DEPENDENCIES += host-vde2
endif
+# Override CPP, as it expects to be able to call it like it'd
+# call the compiler.
define HOST_QEMU_CONFIGURE_CMDS
- cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure \
- --target-list="$(HOST_QEMU_TARGETS)" \
- --prefix="$(HOST_DIR)/usr" \
- --interp-prefix=$(STAGING_DIR) \
- --cc="$(HOSTCC)" \
- --host-cc="$(HOSTCC)" \
- --python=$(HOST_DIR)/usr/bin/python2 \
- --extra-cflags="$(HOST_CFLAGS)" \
- --extra-ldflags="$(HOST_LDFLAGS)" \
+ cd $(@D); $(HOST_CONFIGURE_OPTS) CPP="$(HOSTCC) -E" \
+ ./configure \
+ --target-list="$(HOST_QEMU_TARGETS)" \
+ --prefix="$(HOST_DIR)/usr" \
+ --interp-prefix=$(STAGING_DIR) \
+ --cc="$(HOSTCC)" \
+ --host-cc="$(HOSTCC)" \
+ --python=$(HOST_DIR)/usr/bin/python2 \
+ --extra-cflags="$(HOST_CFLAGS)" \
+ --extra-ldflags="$(HOST_LDFLAGS)" \
$(HOST_QEMU_OPTS)
endef