summaryrefslogtreecommitdiff
path: root/package/qextserialport
diff options
context:
space:
mode:
authorArnout Vandecappelle <arnout@mind.be>2016-11-20 23:13:26 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-21 22:44:07 +0100
commit99b3e821339aeac59c45ddb3c482f4ec3e09ecf6 (patch)
tree32a1f87e779b1c0f33fc82a760844368c2ddf496 /package/qextserialport
parentcbc2fd07b0089e49ecad851bd2ac38f177111d8a (diff)
qextserialport: define QEXTSERIALPORT_CONFIGURE_CMDS only once
Distinguish qt/qt5 by defining QEXTSERIALPORT_QMAKE, like is done e.g. for quazip. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qextserialport')
-rw-r--r--package/qextserialport/qextserialport.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/qextserialport/qextserialport.mk b/package/qextserialport/qextserialport.mk
index 39e04075b..11b1cc89c 100644
--- a/package/qextserialport/qextserialport.mk
+++ b/package/qextserialport/qextserialport.mk
@@ -12,15 +12,15 @@ QEXTSERIALPORT_INSTALL_STAGING = YES
ifeq ($(BR2_PACKAGE_QT),y)
QEXTSERIALPORT_DEPENDENCIES += qt
-define QEXTSERIALPORT_CONFIGURE_CMDS
- (cd $(@D); $(TARGET_MAKE_ENV) $(QT_QMAKE))
-endef
+QEXTSERIALPORT_QMAKE = $(QT_QMAKE)
else ifeq ($(BR2_PACKAGE_QT5),y)
QEXTSERIALPORT_DEPENDENCIES += qt5base
+QEXTSERIALPORT_QMAKE = $(QT5_QMAKE)
+endif
+
define QEXTSERIALPORT_CONFIGURE_CMDS
- (cd $(@D); $(TARGET_MAKE_ENV) $(QT5_QMAKE))
+ (cd $(@D); $(TARGET_MAKE_ENV) $(QEXTSERIALPORT_QMAKE))
endef
-endif
define QEXTSERIALPORT_BUILD_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)