summaryrefslogtreecommitdiff
path: root/package/qt5
diff options
context:
space:
mode:
authorWolfgang Grandegger <wg@grandegger.com>2017-01-18 17:19:28 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2017-01-19 16:28:19 +1100
commit8d153dba65b92a77f3b5e6178d02528c1c330df6 (patch)
tree526183181f614b7f9726d10078b6023d8ab5e126 /package/qt5
parentb759463c15afbe08dadf8131e2b1fa454560dc5a (diff)
qt5base: use libinput if selected
Signed-off-by: Wolfgang Grandegger <wg@grandegger.com> [Thomas: - move condition to a different place in the .mk file, with other similar conditions. - add an 'else' clause to pass -no-libinput in order to explicitly disable libinput support when the libinput package is not available.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5base/qt5base.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/qt5/qt5base/qt5base.mk b/package/qt5/qt5base/qt5base.mk
index 23dba2a18..45ba4e661 100644
--- a/package/qt5/qt5base/qt5base.mk
+++ b/package/qt5/qt5base/qt5base.mk
@@ -161,6 +161,13 @@ else
QT5BASE_CONFIGURE_OPTS += -no-gstreamer
endif
+ifeq ($(BR2_PACKAGE_LIBINPUT),y)
+QT5BASE_CONFIGURE_OPTS += -libinput
+QT5BASE_DEPENDENCIES += libinput
+else
+QT5BASE_CONFIGURE_OPTS += -no-libinput
+endif
+
# Build the list of libraries to be installed on the target
QT5BASE_INSTALL_LIBS_y += Qt5Core
QT5BASE_INSTALL_LIBS_$(BR2_PACKAGE_QT5BASE_XCB) += Qt5XcbQpa