summaryrefslogtreecommitdiff
path: root/package/qt5
diff options
context:
space:
mode:
authorJohan Derycke <johan.derycke@barco.com>2016-10-19 16:35:24 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-10-19 17:49:21 +0200
commitd4b494b71e33a52db55b01c4c8f02d184b708615 (patch)
treeaec4c92d5e3685ce9cac1e470633dea3506f4543 /package/qt5
parentf6dfbfeb53b6ff63ce97ccd95b3aca409ee4ccf4 (diff)
qt5webkit: do not overwrite target python
This commit fixes an issue introduced in commit ac16793eaaabfced0312420759e3a66cdaa1ea8e. This commit creates a link $(@D)/bin/python pointing to the host Python 2, and adds $(@D)/bin/ to the PATH. However, the QT5WEBKIT_INSTALL_TARGET_CMDS variable copies the contents of $(@D)/bin/ to the target filesystem, in order to install binaries produced by the qt5webkit build. By doing this, we overwrite the 'python' symbolic link on the target. In order to fix this, we simply create the 'python' symbolic link used to trick qt5webkit to use python2 on the host in the $(@D)/host-bin/ sub-directory. Signed-off-by: Johan Derycke <johan.derycke@barco.com> Tested-by: Yegor Yefremov <yegorslists@googlemail.com> [Thomas: rework commit log.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt5')
-rw-r--r--package/qt5/qt5webkit/qt5webkit.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/qt5/qt5webkit/qt5webkit.mk b/package/qt5/qt5webkit/qt5webkit.mk
index f300c11d4..378cdf785 100644
--- a/package/qt5/qt5webkit/qt5webkit.mk
+++ b/package/qt5/qt5webkit/qt5webkit.mk
@@ -36,10 +36,10 @@ endif
# QtWebkit's build system uses python, but only supports python2. We work
# around this by forcing python2 early in the PATH, via a python->python2
# symlink.
-QT5WEBKIT_ENV = PATH=$(@D)/bin:$(BR_PATH)
+QT5WEBKIT_ENV = PATH=$(@D)/host-bin:$(BR_PATH)
define QT5WEBKIT_PYTHON2_SYMLINK
- mkdir -p $(@D)/bin
- ln -sf $(HOST_DIR)/usr/bin/python2 $(@D)/bin/python
+ mkdir -p $(@D)/host-bin
+ ln -sf $(HOST_DIR)/usr/bin/python2 $(@D)/host-bin/python
endef
QT5WEBKIT_PRE_CONFIGURE_HOOKS += QT5WEBKIT_PYTHON2_SYMLINK