summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorVlad Zakharov <vzakhar@synopsys.com>2016-08-19 19:18:43 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-08-19 23:07:42 +0200
commit561622e4ef52cc2697abd6e0a21f56f150caef8a (patch)
tree704a2344fa649c2aace3d6cdf3370b6fdc5f47da /package/qt
parentfc61da15f46ca3eba529b71025ef9e5715b49716 (diff)
qt: build using old C++ standard
'std::auto_ptr' is deprecated with gcc-6 but is used in qt4 code. So we have to build using old C++ standard to prevent build failures. qt4 is not being developed no more, so unfortunately we can't update obsolete C++ code and have to add this workaround. Fixes: http://autobuild.buildroot.net/results/54172d55f39b2fcfa5b7fb4d4ee01566678babbc/ and also Qt build for ARC. Signed-off-by: Vlad Zakharov <vzakhar@synopsys.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/qt.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 09b8dc291..8c0ff7b03 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -41,6 +41,11 @@ QT_CFLAGS = $(TARGET_CFLAGS)
QT_CXXFLAGS = $(TARGET_CXXFLAGS)
QT_LDFLAGS = $(TARGET_LDFLAGS)
+# Qt WebKit build fails when gcc-6 is used for build, because
+# 'std::auto_ptr' is deprecated starting from gcc 6.x. So, we have to
+# use an older c++ standard to prevent build failure
+QT_CXXFLAGS += -std=gnu++98
+
# Qt has some assembly function that are not present in thumb1 mode:
# Error: selected processor does not support Thumb mode `swp r3,r7,[r4]'
# so, we desactivate thumb mode