summaryrefslogtreecommitdiff
path: root/package/qt
diff options
context:
space:
mode:
authorJulien D'Ascenzio <jdascenzio@paratronic.fr>2015-04-22 10:34:18 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-26 12:15:30 +0200
commit7619aba496208102e098e24454371b9513ec2f90 (patch)
tree22518e626a90d2261a23a458be0f049f2cfc47a8 /package/qt
parentc90e587c3589a19fe208f872fc1007a1b608058c (diff)
qt: add QT_COORD_TYPE to double option
On ARM-based platforms, qreal is a typedef for float for performance reasons. But we may want a double precision anyway. Signed-off-by: Richard Genoud <richard.genoud@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.in10
-rw-r--r--package/qt/qt.mk5
2 files changed, 15 insertions, 0 deletions
diff --git a/package/qt/Config.in b/package/qt/Config.in
index 43f5a0fc7..83fdeec81 100644
--- a/package/qt/Config.in
+++ b/package/qt/Config.in
@@ -120,6 +120,16 @@ config BR2_PACKAGE_QT_CONFIG_FILE
This option allows to set the path of such a configuration
file, which Buildroot will give to Qt at compile time.
+config BR2_PACKAGE_QT_QT_COORD_TYPE_DOUBLE
+ bool "QT_COORD_TYPE to double"
+ help
+ Set QT_COORD_TYPE to double. On ARM-based platforms, qreal
+ is a typedef for float for performance reasons, but for
+ QT_COORD_TYPE, some people may want to use a double type
+ anyway for precision.
+
+ If unsure say n.
+
config BR2_PACKAGE_QT_QT3SUPPORT
bool "Compatibility with Qt3"
depends on BR2_PACKAGE_QT_GUI_MODULE
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index d1615ae0b..919137b2a 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -46,6 +46,11 @@ QT_CFLAGS += -marm
QT_CXXFLAGS += -marm
endif
+ifeq ($(BR2_PACKAGE_QT_QT_COORD_TYPE_DOUBLE),y)
+QT_CFLAGS += -DQT_COORD_TYPE=double
+QT_CXXFLAGS += -DQT_COORD_TYPE=double
+endif
+
ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
QT_CONFIGURE_OPTS += -qt3support
else