summaryrefslogtreecommitdiff
path: root/package/quagga
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2015-07-09 13:00:11 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-09 22:14:19 +0200
commita3b44fa70cb336604f47ad6c6e1b720b4ac4dd12 (patch)
tree4539ead423a8db44a510935151e738cbb4f493f6 /package/quagga
parent701e75bf3d46405956d2641af187854ae6330790 (diff)
quagga: disable PIE on ARC
Even though ARC gcc understands "-pie" option and attempts to generate PIE binaries as of today PIE is not really supported for user-space applications. So we disable PIE detection if building for ARC. That fixes http://autobuild.buildroot.net/results/ca0/ca0b1e271f29d7639b6a6e895472a35e2c1d8aba and also prevents execution of non-supported PIE binary in runtime. Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/quagga')
-rw-r--r--package/quagga/quagga.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/quagga/quagga.mk b/package/quagga/quagga.mk
index 756d6e0e1..ce1d34b26 100644
--- a/package/quagga/quagga.mk
+++ b/package/quagga/quagga.mk
@@ -39,4 +39,8 @@ else
QUAGGA_CONF_OPTS += --disable-vtysh
endif
+ifeq ($(BR2_arc),y)
+QUAGGA_CONF_OPTS += --disable-pie
+endif
+
$(eval $(autotools-package))