summaryrefslogtreecommitdiff
path: root/package/quota
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-08-14 15:28:01 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-08-16 08:13:21 +0200
commit6d2533bdebdce21df13525cd723daa6837fcd1f5 (patch)
tree36fecdf61892289858bfc451f47252efd7dc8738 /package/quota
parent161746ca8fde099fa2994a00f89f829f02924897 (diff)
package/quota: fix static build with e2fsprogs
quota does not use pkg-config to find e2fsprogs libs, so it misses out on the fact that it may require -pthread when doing static links. Fix that by manually adding -pthread in case of the static build (of course, only if the toolchain has threads). Fixes: http://autobuild.buildroot.org/results/733/733145e94d7c4f3b11e867c60a1e8f8e049a3ce0/ http://autobuild.buildroot.org/results/666/6666f7c07339830fb45a5decb8825560ee432ce5/ http://autobuild.buildroot.org/results/f5b/f5b1d57bd26adaf125555b97ff1eb9faf223a293/ [...] Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/quota')
-rw-r--r--package/quota/quota.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/quota/quota.mk b/package/quota/quota.mk
index c30a2bd85..a1e343a38 100644
--- a/package/quota/quota.mk
+++ b/package/quota/quota.mk
@@ -21,6 +21,11 @@ endif
ifeq ($(BR2_PACKAGE_E2FSPROGS),y)
QUOTA_DEPENDENCIES += e2fsprogs
QUOTA_CONF_OPTS += --enable-ext2direct
+# quote does not use pkg-config to find e2fsprogs, so it does not know it
+# may require -pthreads in case of static build
+ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
+QUOTA_LIBS += -pthread
+endif
else
QUOTA_CONF_OPTS += --disable-ext2direct
endif