summaryrefslogtreecommitdiff
path: root/package/qwt
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2014-09-15 13:29:02 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-15 13:29:02 +0200
commit6de4afc3b4353327eb5a2dc57b9f449a4d14a969 (patch)
treedd69f5d1a8ca0f19d06421431928e25b5d0cef8a /package/qwt
parent643baa18726111492792ddf20a61c141f9e46e9d (diff)
qwt: add optional opengl support
qwt should only build the opengl support code if Qt is configured with opengl support, so add a suboption for it similar to svg/mathml with the needed dependencies. Fixes http://autobuild.buildroot.net/results/597/5977bd77342e28ae9783f9f9edfcf84eefd081b6/ Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/qwt')
-rw-r--r--package/qwt/Config.in6
-rw-r--r--package/qwt/qwt.mk6
2 files changed, 12 insertions, 0 deletions
diff --git a/package/qwt/Config.in b/package/qwt/Config.in
index 3dc6f2275..7718b594a 100644
--- a/package/qwt/Config.in
+++ b/package/qwt/Config.in
@@ -16,6 +16,12 @@ config BR2_PACKAGE_QWT_SVG
config BR2_PACKAGE_QWT_MATHML
bool "MathML support"
+config BR2_PACKAGE_QWT_OPENGL
+ bool "OpenGL support"
+ depends on BR2_PACKAGE_HAS_LIBGLES
+ depends on BR2_PACKAGE_HAS_LIBEGL
+ select BR2_PACKAGE_QT_OPENGL_ES
+
endif
comment "qwt depends on QT gui module"
diff --git a/package/qwt/qwt.mk b/package/qwt/qwt.mk
index 3007bf747..e75d21734 100644
--- a/package/qwt/qwt.mk
+++ b/package/qwt/qwt.mk
@@ -26,6 +26,12 @@ else
QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtMathML.*$$/\# QWT_CONFIG += QwtMathML/'
endif
+ifeq ($(BR2_PACKAGE_QWT_OPENGL),y)
+ QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtOpenGL.*$$/QWT_CONFIG += QwtOpenGL/'
+else
+ QWT_CONFIG += -e 's/^.*QWT_CONFIG.*QwtOpenGL.*$$/\# QWT_CONFIG += QwtOpenGL/'
+endif
+
define QWT_CONFIGURE_CMDS
$(SED) $(QWT_CONFIG) $(@D)/qwtconfig.pri
(cd $(@D); $(TARGET_MAKE_ENV) $(QT_QMAKE))