summaryrefslogtreecommitdiff
path: root/package/redis
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2013-08-28 15:40:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-08-28 16:20:12 +0200
commite5088380d3aa475fe2457fc12a47353dd66c4c19 (patch)
treec2cdcc64034a3a06b785b03b43ce5057b5c7a163 /package/redis
parent027ef3f2b272e5b2d5b258eb4d50e4be8cad0603 (diff)
redis: fix build with ccache enabled
Some parts of redis fail to build when ccache is enabled, due to one of our own patches. The construct make CC=$(CC) target1 target2 would result in make CC=ccache <tuple>-gcc target1 target2 and here <tuple>-gcc would be treated as a target and the compiler used would be just 'ccache'. Reported-by: Johan Sagaert <sagaert.johan@skynet.be> Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/redis')
-rw-r--r--package/redis/redis-001-uclibc.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/redis/redis-001-uclibc.patch b/package/redis/redis-001-uclibc.patch
index 8762ca2fb..01657d0ea 100644
--- a/package/redis/redis-001-uclibc.patch
+++ b/package/redis/redis-001-uclibc.patch
@@ -39,7 +39,7 @@ diff -ur old/src/Makefile new/src/Makefile
echo PREV_FINAL_CFLAGS=$(FINAL_CFLAGS) >> .make-settings
echo PREV_FINAL_LDFLAGS=$(FINAL_LDFLAGS) >> .make-settings
- -(cd ../deps && $(MAKE) $(DEPENDENCY_TARGETS))
-+ -(cd ../deps && $(MAKE) CC=$(CC) $(DEPENDENCY_TARGETS))
++ -(cd ../deps && $(MAKE) CC="$(CC)" $(DEPENDENCY_TARGETS))
.PHONY: persist-settings