summaryrefslogtreecommitdiff
path: root/package/rpm
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@openwide.fr>2015-01-18 20:53:07 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-02-01 22:54:10 +0100
commit652414095e85e6da906f99da6a184f8a31177b60 (patch)
treec52388dc0c49fa7bfc0fb64247cf55750d678baa /package/rpm
parent5b9860150377f8bd6850fea4c2e85027fb6c9064 (diff)
package/rpm: add gettext dependency
rpm check for libintl library if BR2_NEEDS_GETTEXT_IF_LOCALE is set. checking for GNU gettext in libintl... yes checking whether to use NLS... yes checking where the gettext function comes from... external libintl checking how to link with libintl... -lintl But the dependency on gettext package is missing to ensures reproducible builds. Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/rpm')
-rw-r--r--package/rpm/Config.in1
-rw-r--r--package/rpm/rpm.mk4
2 files changed, 5 insertions, 0 deletions
diff --git a/package/rpm/Config.in b/package/rpm/Config.in
index 379b15b42..5ec4167fd 100644
--- a/package/rpm/Config.in
+++ b/package/rpm/Config.in
@@ -7,6 +7,7 @@ config BR2_PACKAGE_RPM
depends on BR2_TOOLCHAIN_HAS_THREADS # beecrypt
depends on BR2_USE_MMU # fork()
select BR2_PACKAGE_BEECRYPT
+ select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
select BR2_PACKAGE_NEON
select BR2_PACKAGE_NEON_SSL
select BR2_PACKAGE_NEON_XML
diff --git a/package/rpm/rpm.mk b/package/rpm/rpm.mk
index c4215b5bc..74f5b888e 100644
--- a/package/rpm/rpm.mk
+++ b/package/rpm/rpm.mk
@@ -26,6 +26,10 @@ RPM_CONF_OPTS = \
--with-libbeecrypt=$(STAGING_DIR) \
--with-popt=$(STAGING_DIR)
+ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
+RPM_DEPENDENCIES += gettext
+endif
+
ifeq ($(BR2_PACKAGE_PCRE),y)
RPM_DEPENDENCIES += pcre
RPM_CONF_OPTS += --with-pcre=external