summaryrefslogtreecommitdiff
path: root/package/rsyslog
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-14 22:07:14 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-14 22:07:14 +0100
commit1f902e743e04e3ee0b91a0400fc6f5a0a276af38 (patch)
tree193b023db6e3deb9e2d0c62b1982abc7a9d0c05a /package/rsyslog
parent20e0d97038b1158fb1e0b1c91ca4cddd9e79f843 (diff)
rsyslog: add 'else' clause to mysql and postgresql support
Having 'else' clauses handling the absence of mysql and postgresql support to explicitly disable such features helps to avoid misdetection of system-installed packages. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/rsyslog')
-rw-r--r--package/rsyslog/rsyslog.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/rsyslog/rsyslog.mk b/package/rsyslog/rsyslog.mk
index fe28d2fcd..1e0953f83 100644
--- a/package/rsyslog/rsyslog.mk
+++ b/package/rsyslog/rsyslog.mk
@@ -40,12 +40,16 @@ ifeq ($(BR2_PACKAGE_MYSQL),y)
RSYSLOG_DEPENDENCIES += mysql
RSYSLOG_CONF_OPTS += --enable-mysql
RSYSLOG_CONF_ENV += ac_cv_prog_MYSQL_CONFIG=$(STAGING_DIR)/usr/bin/mysql_config
+else
+RSYSLOG_CONF_OPTS += --disable-mysql
endif
ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
RSYSLOG_DEPENDENCIES += postgresql
RSYSLOG_CONF_OPTS += --enable-pgsql
RSYSLOG_CONF_ENV += ac_cv_prog_PG_CONFIG=$(STAGING_DIR)/usr/bin/pg_config
+else
+RSYSLOG_CONF_OPTS += --disable-pgsql
endif
ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBUUID),y)