summaryrefslogtreecommitdiff
path: root/package/rsyslog
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-11-30 15:18:46 +0100
committerPeter Korsgaard <peter@korsgaard.com>2014-12-02 00:25:14 +0100
commit8a6482db88fc9f6076bc25f9b2b9defadc8fc809 (patch)
treeaf1afbf389a2c732cb549d3bb19a6102aefc2abe /package/rsyslog
parent1c8369ce3f9d3c3316b36885f9124e5ae89a1837 (diff)
rsyslog: install init script and config file unconditionally
As discussed, users should use a rootfs overlay or a post-build script instead of a custom skeleton to override files installed by Buildroot, so there is no point in having conditions when installing init scripts or configuration files. Also, we take this opportunity to rename RSYSLOG_INSTALL_CONF_SCRIPT to RSYSLOG_INSTALL_CONF because it is no longer installing an init script. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/rsyslog')
-rw-r--r--package/rsyslog/rsyslog.mk14
1 files changed, 6 insertions, 8 deletions
diff --git a/package/rsyslog/rsyslog.mk b/package/rsyslog/rsyslog.mk
index d7dc9303f..6b72bb515 100644
--- a/package/rsyslog/rsyslog.mk
+++ b/package/rsyslog/rsyslog.mk
@@ -39,18 +39,16 @@ else
endif
define RSYSLOG_INSTALL_INIT_SYSV
- [ -f $(TARGET_DIR)/etc/init.d/S01rsyslog ] || \
- $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslog \
- $(TARGET_DIR)/etc/init.d/S01rsyslog
+ $(INSTALL) -m 0755 -D package/rsyslog/S01rsyslog \
+ $(TARGET_DIR)/etc/init.d/S01rsyslog
endef
-define RSYSLOG_INSTALL_CONF_SCRIPT
- [ -f $(TARGET_DIR)/etc/rsyslog.conf ] || \
- $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
- $(TARGET_DIR)/etc/rsyslog.conf
+define RSYSLOG_INSTALL_CONF
+ $(INSTALL) -m 0644 -D $(@D)/platform/redhat/rsyslog.conf \
+ $(TARGET_DIR)/etc/rsyslog.conf
mkdir -p $(TARGET_DIR)/etc/rsyslog.d
endef
-RSYSLOG_POST_INSTALL_TARGET_HOOKS += RSYSLOG_INSTALL_CONF_SCRIPT
+RSYSLOG_POST_INSTALL_TARGET_HOOKS += RSYSLOG_INSTALL_CONF
$(eval $(autotools-package))