summaryrefslogtreecommitdiff
path: root/package/rtptools
diff options
context:
space:
mode:
authorPeter Korsgaard <peter@korsgaard.com>2013-12-02 13:11:31 +0100
committerPeter Korsgaard <peter@korsgaard.com>2013-12-02 13:11:31 +0100
commit735b59b0e09fafe43d8286f037c623a7b156f8bb (patch)
tree02eca939f056415e2a3f36924a2d7d598ef5eadc /package/rtptools
parent8d44089c8e5671708b44176a376fa49c3497a447 (diff)
package: add rtptools
Notice that the license is quite special. It is basically MIT with the difference that it only allows use for: 'research and educational purpose and without fee ... Use of this software in whole or in parts for direct commercial advantage requires explicit prior permission' Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/rtptools')
-rw-r--r--package/rtptools/Config.in7
-rw-r--r--package/rtptools/rtptools-01-host2ip-no-nis-on-uClibc.patch45
-rw-r--r--package/rtptools/rtptools.mk12
3 files changed, 64 insertions, 0 deletions
diff --git a/package/rtptools/Config.in b/package/rtptools/Config.in
new file mode 100644
index 000000000..80bbb7a7a
--- /dev/null
+++ b/package/rtptools/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RTPTOOLS
+ bool "rtptools"
+ help
+ The rtptools distribution consists of a number of small
+ applications that can be used for processing RTP data.
+
+ http://www.cs.columbia.edu/irt/software/rtptools/
diff --git a/package/rtptools/rtptools-01-host2ip-no-nis-on-uClibc.patch b/package/rtptools/rtptools-01-host2ip-no-nis-on-uClibc.patch
new file mode 100644
index 000000000..f1a72f957
--- /dev/null
+++ b/package/rtptools/rtptools-01-host2ip-no-nis-on-uClibc.patch
@@ -0,0 +1,45 @@
+host2ip.c: disable NIS support when building with uClibc
+
+uClibc doesn't have NIS support, so simply disable the fallback.
+
+Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
+---
+ host2ip.c | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+Index: rtptools-1.20/host2ip.c
+===================================================================
+--- rtptools-1.20.orig/host2ip.c
++++ rtptools-1.20/host2ip.c
+@@ -3,7 +3,16 @@
+ #include <netdb.h> /* gethostbyname() */
+ #include <netinet/in.h> /* sockaddr_in */
+ #include <arpa/inet.h> /* inet_addr() */
++
++#include <features.h>
++#ifndef __UCLIBC__
++#define HAVE_YP
++#endif
++
++#ifdef HAVE_YP
+ #include <rpcsvc/ypclnt.h> /* YP */
++#endif
++
+ #include <string.h> /* strlen() added by Akira 12/27/01 */
+ #include "sysdep.h"
+
+@@ -28,6 +37,7 @@
+ else if ((hep = gethostbyname(host))) {
+ in = *(struct in_addr *)(hep->h_addr_list[0]);
+ }
++#ifdef HAVE_YP
+ /* As a last resort, try YP. */
+ else {
+ static char *domain = 0; /* YP domain */
+@@ -39,5 +49,6 @@
+ in.s_addr = inet_addr(value);
+ }
+ }
++#endif
+ return in;
+ } /* host2ip */
diff --git a/package/rtptools/rtptools.mk b/package/rtptools/rtptools.mk
new file mode 100644
index 000000000..2f67bf3f7
--- /dev/null
+++ b/package/rtptools/rtptools.mk
@@ -0,0 +1,12 @@
+################################################################################
+#
+# rtptools
+#
+################################################################################
+
+RTPTOOLS_VERSION = 1.20
+RTPTOOLS_SITE = http://www.cs.columbia.edu/irt/software/rtptools/download/
+RTPTOOLS_LICENSE = MIT-like (research and education only)
+RTPTOOLS_LICENSE_FILES = COPYRIGHT
+
+$(eval $(autotools-package))