summaryrefslogtreecommitdiff
path: root/package/ruby
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-09-06 15:59:26 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-09-06 22:12:10 +0200
commit033d865dabcaec3dedfb81d3433a44c4dbe21422 (patch)
treed99f10fbe5ad09ce760bb8c6c23c3243e4fbf0ed /package/ruby
parent3a61bacdcb4ea99c4b09e83de882747ad210041a (diff)
ruby: don't try to use gmp on the host
When building host-ruby, if gmp seems to be available (for example when host-gmp is built as a dependency of building the toolchain), Ruby tries to use it. Unfortunately, it fails to use it because there is no static version of host-gmp that is built and installed. Since we anyway don't care much about gmp support in host-ruby, simply disable it. This issue was introduced since the bump to Ruby 2.1.0, and this commit fixes: http://autobuild.buildroot.org/results/e19/e197f20bd5ec4aae6d8692d67df4f539a9df33e2/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index 297e9024f..384cc88d5 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -14,7 +14,8 @@ RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
RUBY_MAKE = $(MAKE1)
RUBY_CONF_OPT = --disable-install-doc --disable-rpath
HOST_RUBY_CONF_OPT = --disable-install-doc \
- --with-out-ext=curses,openssl,readline
+ --with-out-ext=curses,openssl,readline \
+ --without-gmp
RUBY_LICENSE = Ruby or BSD-2c, BSD-3c, others
RUBY_LICENSE_FILES = LEGAL COPYING BSDL