summaryrefslogtreecommitdiff
path: root/package/ruby
diff options
context:
space:
mode:
authorPeter Seiderer <ps.report@gmx.net>2014-12-06 00:23:35 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-01-10 17:55:37 +0100
commit20d1d8be0f701391d1581bc69bbab7b071db358e (patch)
tree12747e2e354255b0ea0c3800caab7f14df132c1f /package/ruby
parent9d1aa46c9e42670513d02c428f452fef7baa481a (diff)
ruby: fix verconf.h related build failure
See [1] for failure analysis. Fixes: http://autobuild.buildroot.net/results/c94fef5d2cfb00a336905ae3c110d7680f6d5416/ http://autobuild.buildroot.net/results/4375cb1e325a336dbf59f22f975be9165ad0648a/ [1] http://lists.busybox.net/pipermail/buildroot/2014-December/114273.html Signed-off-by: Peter Seiderer <ps.report@gmx.net> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index 20a2a11be..00a785ca2 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -64,6 +64,13 @@ else
RUBY_CONF_OPTS += --without-gmp
endif
+# workaround for amazing build failure, see
+# http://lists.busybox.net/pipermail/buildroot/2014-December/114273.html
+define RUBY_REMOVE_VERCONF_H
+ rm -f $(@D)/verconf.h
+endef
+RUBY_POST_CONFIGURE_HOOKS += RUBY_REMOVE_VERCONF_H
+
# Remove rubygems and friends, as they need extensions that aren't
# built and a target compiler.
RUBY_EXTENSIONS_REMOVE = rake* rdoc* rubygems*