summaryrefslogtreecommitdiff
path: root/package/ruby
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2014-10-01 19:39:56 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-02 12:06:39 +0200
commit75fb62dd034f6a72b87157b5e5752a98f5019248 (patch)
tree632a623f584dd27918fd5ffc478f6e4920a89bed /package/ruby
parent8a87887095809c48cccf201f1c38b41ffe8ef822 (diff)
ruby: use --disable-rubygems
At least for ruby 2.x we need to --disable-rubygems besides removing the gems files to avoid the requires. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ruby')
-rw-r--r--package/ruby/ruby.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/ruby/ruby.mk b/package/ruby/ruby.mk
index 8c094b5cc..bf341899c 100644
--- a/package/ruby/ruby.mk
+++ b/package/ruby/ruby.mk
@@ -12,7 +12,7 @@ RUBY_DEPENDENCIES = host-pkgconf host-ruby
HOST_RUBY_DEPENDENCIES = host-pkgconf
RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
RUBY_MAKE = $(MAKE1)
-RUBY_CONF_OPT = --disable-install-doc --disable-rpath
+RUBY_CONF_OPT = --disable-install-doc --disable-rpath --disable-rubygems
HOST_RUBY_CONF_OPT = --disable-install-doc \
--with-out-ext=curses,openssl,readline \
--without-gmp