summaryrefslogtreecommitdiff
path: root/package/samba4
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-05-16 13:52:30 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-05-16 21:25:42 +0200
commitc6b4a5fcc4a94d3182c11665ffa6e0531addf053 (patch)
tree953b666b180f04302dcc516e42bdd695ead8e848 /package/samba4
parent5787cf2516a32b921314799a2e84ee5a3a3777c4 (diff)
package/samba4: create tempfile with systemd
With systemd, samba4 will need some special temporary files to be created on each boot, as explained in: packaging/systemd/README Install the provided template file as configuration. However, this is not enough, as even the log directory is a tmpfs in the default Buildroot configuration, so we must also create the log directory on each boot. Hence we append this to the template installed above. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Gustavo Zacarias <gustavo@zacarias.com.ar> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/samba4')
-rw-r--r--package/samba4/samba4.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
index 9ccc6a710..c09706882 100644
--- a/package/samba4/samba4.mk
+++ b/package/samba4/samba4.mk
@@ -165,6 +165,9 @@ define SAMBA4_INSTALL_INIT_SYSTEMD
$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/smb.service
ln -sf ../../../../usr/lib/systemd/system/winbind.service \
$(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/winbind.service
+ $(INSTALL) -D -m 644 $(@D)/packaging/systemd/samba.conf.tmp \
+ $(TARGET_DIR)/etc/tmpfiles.d/samba.conf
+ printf "d /var/log/samba 755 root root\n" >>$(TARGET_DIR)/etc/tmpfiles.d/samba.conf
endef
$(eval $(generic-package))