summaryrefslogtreecommitdiff
path: root/package/samba4
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-17 23:19:16 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-05-26 22:08:36 +0200
commitcfa73104fa8cc12925b56a482e7bd4b200f6be9e (patch)
tree1b2c395c0255dd5872b38518a171c07f38b71e59 /package/samba4
parent549bbba67f5c1656f566b08911aa553e57dc3f59 (diff)
samba4: remove compilation of .pyc files
Now that .py files are globally compiled into .pyc files, we can get rid of the samba4 specific logic doing this compilation. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/samba4')
-rw-r--r--package/samba4/samba4.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/samba4/samba4.mk b/package/samba4/samba4.mk
index 9ccc6a710..bb546f083 100644
--- a/package/samba4/samba4.mk
+++ b/package/samba4/samba4.mk
@@ -118,16 +118,6 @@ define SAMBA4_INSTALL_TARGET_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
endef
-# Samba just installs .py files so the purge causes problems with some tools
-ifeq ($(BR2_PACKAGE_PYTHON_PYC_ONLY),y)
-define SAMBA4_BUILD_PYC_FILES
- PYTHONPATH="$(PYTHON_PATH)" \
- $(HOST_DIR)/usr/bin/python -c "import compileall; \
- compileall.compile_dir('$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages/samba')"
-endef
-SAMBA4_POST_INSTALL_TARGET_HOOKS += SAMBA4_BUILD_PYC_FILES
-endif
-
ifeq ($(BR2_PACKAGE_SAMBA4_AD_DC),)
SAMBA4_CONF_OPTS += --without-ad-dc
endif