summaryrefslogtreecommitdiff
path: root/package/sconeserver
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-08-28 20:19:53 +0200
committerPeter Korsgaard <peter@korsgaard.com>2016-08-29 00:04:03 +0200
commit822247827c8ce228540ec5c3027bd01fd0b91480 (patch)
tree61083f7600a5ba3c98ee293793982d70629c074e /package/sconeserver
parenta2e178d6b45dfc5b8d1d50fcbbfc0bec5ebf1ae2 (diff)
package/sconeserver: unconditionally needs host-pkgconf
sconeserver uses pkg-config macros and uses autoreconf, so it unconditionally needs host-pkgconf. [Peter: drop host-pkgconf from sub options, update description] Reported-by: Matthew Weber <matt@thewebers.ws> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/sconeserver')
-rw-r--r--package/sconeserver/sconeserver.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
index e02c1a66f..793ca6fb2 100644
--- a/package/sconeserver/sconeserver.mk
+++ b/package/sconeserver/sconeserver.mk
@@ -10,7 +10,7 @@ SCONESERVER_LICENSE = GPLv2+
SCONESERVER_LICENSE_FILES = COPYING
# fetching from Git, we need to generate the configure script
SCONESERVER_AUTORECONF = YES
-SCONESERVER_DEPENDENCIES += pcre
+SCONESERVER_DEPENDENCIES = host-pkgconf pcre
# disable markdown module because its git submodule cmark
# https://github.com/sconemad/sconeserver/tree/master/markdown
# has no cross-compile support provided by the sconeserver build system
@@ -46,7 +46,7 @@ SCONESERVER_CONF_OPTS += --without-sconesite
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
-SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
+SCONESERVER_DEPENDENCIES += imagemagick
SCONESERVER_CONF_OPTS += \
--with-sconesite-image \
--with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
@@ -79,7 +79,7 @@ SCONESERVER_CONF_OPTS += --without-rss
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
-SCONESERVER_DEPENDENCIES += host-pkgconf gpsd
+SCONESERVER_DEPENDENCIES += gpsd
SCONESERVER_CONF_OPTS += --with-location
else
SCONESERVER_CONF_OPTS += --without-location