summaryrefslogtreecommitdiff
path: root/package/sconeserver
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/sconeserver
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sconeserver')
-rw-r--r--package/sconeserver/sconeserver.mk56
1 files changed, 28 insertions, 28 deletions
diff --git a/package/sconeserver/sconeserver.mk b/package/sconeserver/sconeserver.mk
index 0fef6e771..6b9146933 100644
--- a/package/sconeserver/sconeserver.mk
+++ b/package/sconeserver/sconeserver.mk
@@ -13,103 +13,103 @@ SCONESERVER_LICENSE_FILES = COPYING
SCONESERVER_AUTORECONF = YES
SCONESERVER_DEPENDENCIES += pcre
-SCONESERVER_CONF_OPT += --with-ip --with-local
+SCONESERVER_CONF_OPTS += --with-ip --with-local
# Sconeserver configure script fails to find the libxml2 headers.
ifeq ($(BR2_PACKAGE_LIBXML2),y)
- SCONESERVER_CONF_OPT += \
+ SCONESERVER_CONF_OPTS += \
--with-xml2-config="$(STAGING_DIR)/usr/bin/xml2-config"
endif
ifeq ($(BR2_INET_IPV6),y)
- SCONESERVER_CONF_OPT += --with-ip6
+ SCONESERVER_CONF_OPTS += --with-ip6
else
- SCONESERVER_CONF_OPT += --without-ip6
+ SCONESERVER_CONF_OPTS += --without-ip6
endif
ifeq ($(BR2_PACKAGE_OPENSSL),y)
SCONESERVER_DEPENDENCIES += openssl
- SCONESERVER_CONF_OPT += --with-ssl
+ SCONESERVER_CONF_OPTS += --with-ssl
else
- SCONESERVER_CONF_OPT += --without-ssl
+ SCONESERVER_CONF_OPTS += --without-ssl
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_EXAMPLES),y)
- SCONESERVER_CONF_OPT += --with-examples
+ SCONESERVER_CONF_OPTS += --with-examples
else
- SCONESERVER_CONF_OPT += --without-examples
+ SCONESERVER_CONF_OPTS += --without-examples
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE),y)
SCONESERVER_DEPENDENCIES += libxml2
- SCONESERVER_CONF_OPT += --with-sconesite
+ SCONESERVER_CONF_OPTS += --with-sconesite
else
- SCONESERVER_CONF_OPT += --without-sconesite
+ SCONESERVER_CONF_OPTS += --without-sconesite
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_HTTP_SCONESITE_IMAGE),y)
SCONESERVER_DEPENDENCIES += imagemagick host-pkgconf
- SCONESERVER_CONF_OPT += \
+ SCONESERVER_CONF_OPTS += \
--with-sconesite-image \
--with-Magick++-config="$(STAGING_DIR)/usr/bin/Magick++-config"
else
- SCONESERVER_CONF_OPT += --without-sconesite-image
+ SCONESERVER_CONF_OPTS += --without-sconesite-image
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_MYSQL),y)
SCONESERVER_DEPENDENCIES += mysql
- SCONESERVER_CONF_OPT += --with-mysql \
+ SCONESERVER_CONF_OPTS += --with-mysql \
--with-mysql_config="$(STAGING_DIR)/usr/bin/mysql_config" \
LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib/mysql"
else
- SCONESERVER_CONF_OPT += --without-mysql
+ SCONESERVER_CONF_OPTS += --without-mysql
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_BLUETOOTH),y)
SCONESERVER_DEPENDENCIES += bluez_utils
- SCONESERVER_CONF_OPT += --with-bluetooth
+ SCONESERVER_CONF_OPTS += --with-bluetooth
else
- SCONESERVER_CONF_OPT += --without-bluetooth
+ SCONESERVER_CONF_OPTS += --without-bluetooth
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_RSS),y)
SCONESERVER_DEPENDENCIES += libxml2
- SCONESERVER_CONF_OPT += --with-rss
+ SCONESERVER_CONF_OPTS += --with-rss
else
- SCONESERVER_CONF_OPT += --without-rss
+ SCONESERVER_CONF_OPTS += --without-rss
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_LOCATION),y)
SCONESERVER_DEPENDENCIES += gpsd
- SCONESERVER_CONF_OPT += --with-location
+ SCONESERVER_CONF_OPTS += --with-location
else
- SCONESERVER_CONF_OPT += --without-location
+ SCONESERVER_CONF_OPTS += --without-location
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_LETTUCE),y)
- SCONESERVER_CONF_OPT += --with-lettuce
+ SCONESERVER_CONF_OPTS += --with-lettuce
else
- SCONESERVER_CONF_OPT += --without-lettuce
+ SCONESERVER_CONF_OPTS += --without-lettuce
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_MATHS),y)
SCONESERVER_DEPENDENCIES += mpfr
- SCONESERVER_CONF_OPT += --with-maths
+ SCONESERVER_CONF_OPTS += --with-maths
else
- SCONESERVER_CONF_OPT += --without-maths
+ SCONESERVER_CONF_OPTS += --without-maths
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_TESTBUILDER),y)
- SCONESERVER_CONF_OPT += --with-testbuilder
+ SCONESERVER_CONF_OPTS += --with-testbuilder
else
- SCONESERVER_CONF_OPT += --without-testbuilder
+ SCONESERVER_CONF_OPTS += --without-testbuilder
endif
ifeq ($(BR2_PACKAGE_SCONESERVER_UI),y)
SCONESERVER_DEPENDENCIES += xlib_libX11
- SCONESERVER_CONF_OPT += --with-ui
+ SCONESERVER_CONF_OPTS += --with-ui
else
- SCONESERVER_CONF_OPT += --without-ui
+ SCONESERVER_CONF_OPTS += --without-ui
endif
$(eval $(autotools-package))