summaryrefslogtreecommitdiff
path: root/package/scrypt
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-28 14:59:51 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-08-28 14:59:51 +0200
commit0d83de383224c65ec250a005130b1d3cc6fd6d76 (patch)
treecb79fcdaf9d8fc731dd7b7f32620ae1515e62a27 /package/scrypt
parent84face61cf1dfefe864d6d47976932a32bbde9f2 (diff)
scrypt: commit packaging improvements
The changes brought by this commit should have been part of the previous commit, but were not due to a mistake. This commit implements the following changes to the scrypt package: - move from "Libraries -> Crypto" to "System tools", since it only installs one binary, scrypt, and no library. - bump from 1.1.6 to 1.2.0 - add comment in the .hash file explaining where the hash is coming from. - add missing dependency on OpenSSL - use BSD-2c as the license code, instead of BSD2 - use 'main.c' as the license file. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/scrypt')
-rw-r--r--package/scrypt/Config.in7
-rw-r--r--package/scrypt/scrypt.hash3
-rw-r--r--package/scrypt/scrypt.mk6
3 files changed, 10 insertions, 6 deletions
diff --git a/package/scrypt/Config.in b/package/scrypt/Config.in
index 8be7f5410..e6d1ac1a6 100644
--- a/package/scrypt/Config.in
+++ b/package/scrypt/Config.in
@@ -1,8 +1,9 @@
config BR2_PACKAGE_SCRYPT
bool "scrypt"
+ select BR2_PACKAGE_OPENSSL
help
- A password-based key derivation function specifically designed
- to make it costly to perform large-scale custom hardware attacks
- by requiring large amounts of memory.
+ A password-based key derivation function specifically
+ designed to make it costly to perform large-scale custom
+ hardware attacks by requiring large amounts of memory.
http://www.tarsnap.com/scrypt.html
diff --git a/package/scrypt/scrypt.hash b/package/scrypt/scrypt.hash
index e6b690e24..669445676 100644
--- a/package/scrypt/scrypt.hash
+++ b/package/scrypt/scrypt.hash
@@ -1 +1,2 @@
-sha256 dfd0d1a544439265bbb9b58043ad3c8ce50a3987b44a61b1d39fd7a3ed5b7fb8 scrypt-1.1.6.tgz
+# From http://www.tarsnap.com/scrypt/scrypt-sigs-1.2.0.asc
+sha256 1754bc89405277c8ac14220377a4c240ddc34b1ce70882aa92cd01bfdc8569d4 scrypt-1.2.0.tgz
diff --git a/package/scrypt/scrypt.mk b/package/scrypt/scrypt.mk
index 2db6e2e89..7ffa7ccf3 100644
--- a/package/scrypt/scrypt.mk
+++ b/package/scrypt/scrypt.mk
@@ -4,10 +4,12 @@
#
################################################################################
-SCRYPT_VERSION = 1.1.6
+SCRYPT_VERSION = 1.2.0
SCRYPT_SOURCE = scrypt-$(SCRYPT_VERSION).tgz
SCRYPT_SITE = http://www.tarsnap.com/scrypt
-SCRYPT_LICENSE = BSD2
+SCRYPT_LICENSE = BSD-2c
+SCRYPT_LICENSE_FILES = main.c
+SCRYPT_DEPENDENCIES = openssl
SCRYPT_INSTALL_STAGING = YES
$(eval $(autotools-package))