summaryrefslogtreecommitdiff
path: root/package/sdl2_ttf
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-07-23 12:19:42 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-24 15:03:31 +0200
commit0ccc5b717e2db1df7c1c98071ffc62a8c0aa0c45 (patch)
tree354ef87a354732c618a263883d5799f2b65f7224 /package/sdl2_ttf
parent5eecaf354ced9f322707fa07bb75570d209850e3 (diff)
package/sdl2_ttf: x-includes and x-libraries must be set for cross-compiling
If those flags are not explicitly passed, the sdl2_ttf configure script will include -I/usr/include and -L/usr/lib in the compile flags, which are obviously unsafe for cross-compilation. "checking for X... libraries /usr/lib, headers /usr/include" Fixes: http://autobuild.buildroot.net/results/f968fb31e9882cc856296a7c729d93e345e9e861 Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: - don't pass an argument to --with-x - use --without-x instead of --with-x=no] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sdl2_ttf')
-rw-r--r--package/sdl2_ttf/sdl2_ttf.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/sdl2_ttf/sdl2_ttf.mk b/package/sdl2_ttf/sdl2_ttf.mk
index 71c5bc7a4..6834d16cb 100644
--- a/package/sdl2_ttf/sdl2_ttf.mk
+++ b/package/sdl2_ttf/sdl2_ttf.mk
@@ -14,4 +14,17 @@ SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
SDL2_TTF_CONF_ENV = \
FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
+# x-includes and x-libraries must be set for cross-compiling
+# By default x_includes and x_libraries contains unsafe paths.
+# (/usr/include and /usr/lib)
+ifeq ($(BR2_PACKAGE_SDL2_X11),y)
+SDL2_TTF_CONF_OPTS += \
+ --with-x \
+ --x-includes=$(STAGING_DIR)/usr/include \
+ --x-libraries=$(STAGING_DIR)/usr/lib
+else
+SDL2_TTF_CONF_OPTS += \
+ --without-x
+endif
+
$(eval $(autotools-package))