summaryrefslogtreecommitdiff
path: root/package/sdl2_ttf
diff options
context:
space:
mode:
authorPeter Thompson <peter.macleod.thompson@gmail.com>2016-07-12 08:53:05 -0600
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-15 16:34:20 +0200
commita0abce838bd3167e44c79b2e235125b9c7aa5f23 (patch)
treedb44cdb235c277476f4e9cfee0834dce22cd295a /package/sdl2_ttf
parentf2ffe91eab49ba357c39f2bb1b5cb5450f5a84e7 (diff)
sdl2_ttf: new package
Signed-off-by: Peter Thompson <peter.macleod.thompson@gmail.com> [Thomas: - point <pkg>_LICENSE_FILES to a file that actually exists - add host-pkgconf to the dependencies - remove unneeded CONF_OPTS options - pass FREETYPE_CONFIG in the environment to point to freetype-config] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sdl2_ttf')
-rw-r--r--package/sdl2_ttf/Config.in9
-rw-r--r--package/sdl2_ttf/sdl2_ttf.hash2
-rw-r--r--package/sdl2_ttf/sdl2_ttf.mk17
3 files changed, 28 insertions, 0 deletions
diff --git a/package/sdl2_ttf/Config.in b/package/sdl2_ttf/Config.in
new file mode 100644
index 000000000..cb77059ae
--- /dev/null
+++ b/package/sdl2_ttf/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SDL2_TTF
+ bool "SDL2_TTF"
+ depends on BR2_PACKAGE_SDL2
+ select BR2_PACKAGE_FREETYPE
+ help
+ SDL2_ttf is a sample TrueType font library. It allows you to
+ use TrueType fonts in your SDL2 applications.
+
+ http://www.libsdl.org/projects/SDL_ttf/
diff --git a/package/sdl2_ttf/sdl2_ttf.hash b/package/sdl2_ttf/sdl2_ttf.hash
new file mode 100644
index 000000000..515189afd
--- /dev/null
+++ b/package/sdl2_ttf/sdl2_ttf.hash
@@ -0,0 +1,2 @@
+# Locally calculated
+sha256 34db5e20bcf64e7071fe9ae25acaa7d72bdc4f11ab3ce59acc768ab62fe39276 SDL2_ttf-2.0.14.tar.gz
diff --git a/package/sdl2_ttf/sdl2_ttf.mk b/package/sdl2_ttf/sdl2_ttf.mk
new file mode 100644
index 000000000..71c5bc7a4
--- /dev/null
+++ b/package/sdl2_ttf/sdl2_ttf.mk
@@ -0,0 +1,17 @@
+################################################################################
+#
+# sdl2_ttf
+#
+################################################################################
+
+SDL2_TTF_VERSION = 2.0.14
+SDL2_TTF_SOURCE = SDL2_ttf-$(SDL2_TTF_VERSION).tar.gz
+SDL2_TTF_SITE = http://www.libsdl.org/projects/SDL_ttf/release
+SDL2_TTF_LICENSE = zlib
+SDL2_TTF_LICENSE_FILES = COPYING.txt
+SDL2_TTF_INSTALL_STAGING = YES
+SDL2_TTF_DEPENDENCIES = sdl2 freetype host-pkgconf
+SDL2_TTF_CONF_ENV = \
+ FREETYPE_CONFIG=$(STAGING_DIR)/usr/bin/freetype-config
+
+$(eval $(autotools-package))