summaryrefslogtreecommitdiff
path: root/package/ser2net
diff options
context:
space:
mode:
authorRomain Naour <romain.naour@gmail.com>2016-11-06 14:15:23 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-11-06 15:11:21 +0100
commitd02655cd2157636d6150daf3a1344b25141780c1 (patch)
tree8a0d305b8c5f8407c8cbf613f70d3c07a99332bc /package/ser2net
parent271756da6749a2d88ca9744cb56f25a8c822123e (diff)
package/ser2net: disable threads for toolchains without threads support
ser2net configure script provide an option to disable threads support, use it. Fixes: http://autobuild.buildroot.net/results/6bc/6bc0f99917c2069a1614f4cfcaa98af1b21762e4 Signed-off-by: Romain Naour <romain.naour@gmail.com> [Thomas: use --{with,without}-pthreads instead of --with-pthreads={yes,no}.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/ser2net')
-rw-r--r--package/ser2net/ser2net.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/ser2net/ser2net.mk b/package/ser2net/ser2net.mk
index 01aee95d6..c4dcaf31f 100644
--- a/package/ser2net/ser2net.mk
+++ b/package/ser2net/ser2net.mk
@@ -9,6 +9,12 @@ SER2NET_SITE = http://downloads.sourceforge.net/project/ser2net/ser2net
SER2NET_LICENSE = GPLv2+
SER2NET_LICENSE_FILES = COPYING
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+SER2NET_CONF_OPTS += --with-pthreads
+else
+SER2NET_CONF_OPTS += --without-pthreads
+endif
+
define SER2NET_INSTALL_INIT_SYSV
$(INSTALL) -D -m 755 package/ser2net/S50ser2net \
$(TARGET_DIR)/etc/init.d/S50ser2net