summaryrefslogtreecommitdiff
path: root/package/setools
diff options
context:
space:
mode:
authorClayton Shotwell <clayton.shotwell@rockwellcollins.com>2015-07-15 12:31:04 -0500
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-07-16 23:41:39 +0200
commit0daffc0b65aa86d6d5bc6916736e0cffcdf540cc (patch)
tree32231e1f804ab7134b8c284a9bbce9b9019b751d /package/setools
parente6766f3e442d0396f123e2b67e50fcbd2bcc2d29 (diff)
setools: Add missing bison dependency
The setools package needs the yacc utility which is part of the bison package to build. Fixes http://autobuild.buildroot.net/results/8f9/8f95e83411552397ca29e9aee5c457a1a762b364/ Signed-off-by: Clayton Shotwell <clayton.shotwell@rockwellcollins.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/setools')
-rw-r--r--package/setools/setools.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/setools/setools.mk b/package/setools/setools.mk
index 912daf82a..a2bfd420e 100644
--- a/package/setools/setools.mk
+++ b/package/setools/setools.mk
@@ -7,7 +7,7 @@
SETOOLS_VERSION = 3.3.8
SETOOLS_SOURCE = setools-$(SETOOLS_VERSION).tar.bz2
SETOOLS_SITE = https://raw.githubusercontent.com/wiki/TresysTechnology/setools3/files/dists/setools-$(SETOOLS_VERSION)/
-SETOOLS_DEPENDENCIES = libselinux libsepol sqlite libxml2 bzip2
+SETOOLS_DEPENDENCIES = libselinux libsepol sqlite libxml2 bzip2 host-bison
SETOOLS_INSTALL_STAGING = YES
SETOOLS_LICENSE = GPLv2+ LGPLv2.1+
SETOOLS_LICENSE_FILES = COPYING COPYING.GPL COPYING.LGPL
@@ -32,7 +32,7 @@ SETOOLS_CONF_OPTS = \
--with-selinux-devel="$(STAGING_DIR)/usr"
HOST_SETOOLS_DEPENDENCIES = host-libselinux host-libsepol host-sqlite \
- host-libxml2 host-bzip2
+ host-libxml2 host-bzip2 host-bison
ifeq ($(BR2_PACKAGE_PYTHON3),y)
HOST_SETOOLS_PYTHON_VERSION=$(PYTHON3_VERSION_MAJOR)