summaryrefslogtreecommitdiff
path: root/package/shapelib
diff options
context:
space:
mode:
authorZoltan Gyarmati <mr.zoltan.gyarmati@gmail.com>2016-07-31 14:45:50 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-09-21 15:55:23 +0200
commit2655d676f0151f6cfd36c42435cf84926c209e24 (patch)
tree2e1c486440020bf499cc26ef03d1d25c6591e28f /package/shapelib
parent589cbc61b0913891fd00019365e52b9e50ff7250 (diff)
shapelib: new package
Signed-off-by: Zoltan Gyarmati <mr.zoltan.gyarmati@gmail.com> [Thomas: - adjust the license: it's MIT or LGPLv2, add web/license.html to the license files - rewrap Config.in help text - add entry to the DEVELOPERS file.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/shapelib')
-rw-r--r--package/shapelib/Config.in9
-rw-r--r--package/shapelib/shapelib.hash2
-rw-r--r--package/shapelib/shapelib.mk25
3 files changed, 36 insertions, 0 deletions
diff --git a/package/shapelib/Config.in b/package/shapelib/Config.in
new file mode 100644
index 000000000..aa2297b27
--- /dev/null
+++ b/package/shapelib/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SHAPELIB
+ bool "shapelib"
+ help
+ The Shapefile C Library provides the ability to write simple
+ C programs for reading, writing and updating (to a limited
+ extent) ESRI Shapefiles, and the associated attribute file
+ (.dbf).
+
+ http://shapelib.maptools.org/
diff --git a/package/shapelib/shapelib.hash b/package/shapelib/shapelib.hash
new file mode 100644
index 000000000..f3f812ebf
--- /dev/null
+++ b/package/shapelib/shapelib.hash
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 23d474016158ab5077db2f599527631706ba5c0dc7c4178a6a1d685bb014f68f shapelib-1.3.0.tar.gz
diff --git a/package/shapelib/shapelib.mk b/package/shapelib/shapelib.mk
new file mode 100644
index 000000000..1e9c16f33
--- /dev/null
+++ b/package/shapelib/shapelib.mk
@@ -0,0 +1,25 @@
+################################################################################
+#
+# shapelib
+#
+################################################################################
+
+SHAPELIB_VERSION = 1.3.0
+SHAPELIB_SITE = http://download.osgeo.org/shapelib
+SHAPELIB_LICENSE = MIT or LGPLv2
+SHAPELIB_LICENSE_FILES = web/license.html LICENSE.LGPL
+SHAPELIB_INSTALL_STAGING = YES
+
+define SHAPELIB_BUILD_CMDS
+ $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
+endef
+
+define SHAPELIB_INSTALL_STAGING_CMDS
+ $(MAKE) -C $(@D) PREFIX=$(STAGING_DIR)/usr/ lib_install
+endef
+
+define SHAPELIB_INSTALL_TARGET_CMDS
+ $(MAKE) -C $(@D) PREFIX=$(TARGET_DIR)/usr/ bin_install
+endef
+
+$(eval $(generic-package))