summaryrefslogtreecommitdiff
path: root/package/sigrok-cli
diff options
context:
space:
mode:
authorBartosz Golaszewski <bgolaszewski@baylibre.com>2015-01-29 12:35:39 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-02-01 23:47:34 +0100
commit793486e687c5c56b0dfda99ad6ecd603058dba38 (patch)
tree83b65a6a77900d2c1174f5b8a23a616990228bfa /package/sigrok-cli
parent0310aa70c234ef6c2edfd5e10cff98295c3e362c (diff)
sigrok-cli: new package
[Peter: needs host-pkgconf, simplify pre configure hook] Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/sigrok-cli')
-rw-r--r--package/sigrok-cli/Config.in17
-rw-r--r--package/sigrok-cli/sigrok-cli.mk23
2 files changed, 40 insertions, 0 deletions
diff --git a/package/sigrok-cli/Config.in b/package/sigrok-cli/Config.in
new file mode 100644
index 000000000..e3e5420ab
--- /dev/null
+++ b/package/sigrok-cli/Config.in
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_SIGROK_CLI
+ bool "sigrok-cli"
+ select BR2_PACKAGE_LIBSERIALPORT
+ select BR2_PACKAGE_LIBSIGROK
+ # libsigrok->libglib2:
+ depends on BR2_USE_WCHAR
+ depends on BR2_TOOLCHAIN_HAS_THREADS
+ depends on BR2_USE_MMU
+ help
+ Sigrok-cli is a command-line frontend for the sigrok
+ software suite.
+
+ http://sigrok.org/wiki/Sigrok-cli
+
+comment "sigrok-cli needs a toolchain w/ wchar, threads"
+ depends on BR2_USE_MMU
+ depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/sigrok-cli/sigrok-cli.mk b/package/sigrok-cli/sigrok-cli.mk
new file mode 100644
index 000000000..6051d6d12
--- /dev/null
+++ b/package/sigrok-cli/sigrok-cli.mk
@@ -0,0 +1,23 @@
+################################################################################
+#
+# sigrok-cli
+#
+################################################################################
+
+SIGROK_CLI_VERSION = 198487f611d8a7be4fa15017c22fa01a56551ca6
+# No https access on upstream git
+SIGROK_CLI_SITE = git://sigrok.org/sigrok-cli
+SIGROK_CLI_LICENSE = GPLv3+
+SIGROK_CLI_LICENSE_FILES = COPYING
+# Git checkout has no configure script
+SIGROK_CLI_AUTORECONF = YES
+SIGROK_CLI_DEPENDENCIES = host-pkgconf libsigrok
+SIGROK_CLI_CONF_OPTS = --with-libsigrokdecode=NO
+
+define SIGROK_CLI_ADD_MISSING
+ mkdir -p $(@D)/autostuff
+endef
+
+SIGROK_CLI_PRE_CONFIGURE_HOOKS += SIGROK_CLI_ADD_MISSING
+
+$(eval $(autotools-package))