summaryrefslogtreecommitdiff
path: root/package/skeleton
diff options
context:
space:
mode:
authorThomas De Schampheleire <thomas.de.schampheleire@gmail.com>2016-01-20 20:11:28 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-01-20 21:49:14 +0100
commit50a93866f0851a9cd06feb95c556f007bc578af1 (patch)
tree0f7109e5500454fa1a5defb8c7cb12f1f3b0ada7 /package/skeleton
parentd7e7ad4f34b693d5d0f83c39a6047c6dd6c9bcc3 (diff)
skeleton: move LIB_SYMLINK definition from Makefile
Commit 7a6b83a211612ff95a1f5d35b2861ad5655ac8b1 introduced the skeleton package, which took over the lib32/lib64 -> lib symlink creation from the main Makefile. However, the definition of the LIB_SYMLINK variable did not move along, for no real reason. Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Cc: Arnout Vandecappelle <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/skeleton')
-rw-r--r--package/skeleton/skeleton.mk16
1 files changed, 12 insertions, 4 deletions
diff --git a/package/skeleton/skeleton.mk b/package/skeleton/skeleton.mk
index 6b5ab79e1..761883567 100644
--- a/package/skeleton/skeleton.mk
+++ b/package/skeleton/skeleton.mk
@@ -77,13 +77,21 @@ define SKELETON_USR_SYMLINKS_OR_DIRS
endef
endif
+# We make a symlink lib32->lib or lib64->lib as appropriate
+# MIPS64/n32 requires lib32 even though it's a 64-bit arch.
+ifeq ($(BR2_ARCH_IS_64)$(BR2_MIPS_NABI32),y)
+SKELETON_LIB_SYMLINK = lib64
+else
+SKELETON_LIB_SYMLINK = lib32
+endif
+
define SKELETON_INSTALL_TARGET_CMDS
rsync -a --ignore-times $(RSYNC_VCS_EXCLUSIONS) \
--chmod=u=rwX,go=rX --exclude .empty --exclude '*~' \
$(SKELETON_PATH)/ $(TARGET_DIR)/
$(call SKELETON_USR_SYMLINKS_OR_DIRS,$(TARGET_DIR))
- ln -snf lib $(TARGET_DIR)/$(LIB_SYMLINK)
- ln -snf lib $(TARGET_DIR)/usr/$(LIB_SYMLINK)
+ ln -snf lib $(TARGET_DIR)/$(SKELETON_LIB_SYMLINK)
+ ln -snf lib $(TARGET_DIR)/usr/$(SKELETON_LIB_SYMLINK)
$(INSTALL) -m 0644 support/misc/target-dir-warning.txt \
$(TARGET_DIR_WARNING_FILE)
endef
@@ -99,8 +107,8 @@ define SKELETON_INSTALL_STAGING_CMDS
$(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/sbin
$(INSTALL) -d -m 0755 $(STAGING_DIR)/usr/include
$(call SKELETON_USR_SYMLINKS_OR_DIRS,$(STAGING_DIR))
- ln -snf lib $(STAGING_DIR)/$(LIB_SYMLINK)
- ln -snf lib $(STAGING_DIR)/usr/$(LIB_SYMLINK)
+ ln -snf lib $(STAGING_DIR)/$(SKELETON_LIB_SYMLINK)
+ ln -snf lib $(STAGING_DIR)/usr/$(SKELETON_LIB_SYMLINK)
endef
SKELETON_TARGET_GENERIC_HOSTNAME = $(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))