summaryrefslogtreecommitdiff
path: root/package/skeleton
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-07-17 10:44:27 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-18 23:45:34 +0200
commit65329a102485c7a760a0129643b128f44c73c0f4 (patch)
treeaa4e1893c47acc5bc535c3939b38ac9f8f12eb23 /package/skeleton
parenta661e0ba5eb44d8d9fbd8845b3c4e6cc28c728c5 (diff)
system: do not handle network settings for custom skeleton
We expect the custom skeleton to be fully filled with the necessary files, now. There is definitely no reason we should handle network settings in there. A user using a custom skeleton should be fully responsible for providing a functional skeleton. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/skeleton')
-rw-r--r--package/skeleton/skeleton.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/skeleton/skeleton.mk b/package/skeleton/skeleton.mk
index d580fcbff..43496202c 100644
--- a/package/skeleton/skeleton.mk
+++ b/package/skeleton/skeleton.mk
@@ -141,6 +141,10 @@ endef
TARGET_FINALIZE_HOOKS += SKELETON_SET_ISSUE
endif
+# The TARGET_FINALIZE_HOOKS must be sourced only if the users choose to use the
+# default skeleton.
+ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
+
define SKELETON_SET_NETWORK_LOCALHOST
( \
echo "# interface file auto-generated by buildroot"; \
@@ -174,10 +178,6 @@ endef
TARGET_FINALIZE_HOOKS += SKELETON_SET_NETWORK
-# The TARGET_FINALIZE_HOOKS must be sourced only if the users choose to use the
-# default skeleton.
-ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
-
ifeq ($(BR2_TARGET_ENABLE_ROOT_LOGIN),y)
ifeq ($(SKELETON_TARGET_GENERIC_ROOT_PASSWD),)
SKELETON_ROOT_PASSWORD =