summaryrefslogtreecommitdiff
path: root/package/skeleton
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2015-11-10 22:36:29 +0100
committerPeter Korsgaard <peter@korsgaard.com>2015-11-10 23:47:14 +0100
commitaab5a2829be17bf7d5472c480ccfee9842763dc8 (patch)
treeb3aa96000d9e9fe2eefdbbbb36a347852141edb6 /package/skeleton
parent8d9b39a979efde32cc2ebc35912f0f8fdc1ba8fe (diff)
package/skeleton: don't handle merged /usr for custom skeleton
In case the user wants to use a custom skeleton, we should not try to handle the symlinks (resp. mkdir) to handle merged (resp. split) /usr. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Maxime Hadjinlian <maxime.hadjinlian@gmail.com> Cc: Peter Korsgaard <jacmet@uclibc.org> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/skeleton')
-rw-r--r--package/skeleton/skeleton.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/skeleton/skeleton.mk b/package/skeleton/skeleton.mk
index 11a609b01..38391def8 100644
--- a/package/skeleton/skeleton.mk
+++ b/package/skeleton/skeleton.mk
@@ -15,9 +15,9 @@ SKELETON_ADD_TOOLCHAIN_DEPENDENCY = NO
ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
SKELETON_PATH = $(call qstrip,$(BR2_ROOTFS_SKELETON_CUSTOM_PATH))
-else
+else # ! custom skeleton
+
SKELETON_PATH = system/skeleton
-endif
ifeq ($(BR2_ROOTFS_MERGED_USR),y)
define SKELETON_USR_SYMLINKS_OR_DIRS
@@ -33,6 +33,8 @@ define SKELETON_USR_SYMLINKS_OR_DIRS
endef
endif
+endif # ! custom skeleton
+
define SKELETON_INSTALL_TARGET_CMDS
rsync -a --ignore-times $(SYNC_VCS_EXCLUSIONS) \
--chmod=u=rwX,go=rX --exclude .empty --exclude '*~' \