summaryrefslogtreecommitdiff
path: root/package/skeleton
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-07-17 10:44:25 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-07-18 23:40:06 +0200
commitb541b9ff94af8d0464deeb6e902dcc653b9c44b4 (patch)
tree1fcac09f4f061934411c0d7abe0baae3ee4013b7 /package/skeleton
parentfbbd7ce201a35312c0288467a24601b2658c359f (diff)
system: provide no default for custom skeleton path
Being custom means that our default one is not suitable to start with. So there is no reason to offer it as the default path. Add a check that it is not empty. Add a separating empty line, for good measure, too. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Romain Naour <romain.naour@openwide.fr> Cc: Arnout Vandecappelle <arnout@mind.be> Reviewed-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/skeleton')
-rw-r--r--package/skeleton/skeleton.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/skeleton/skeleton.mk b/package/skeleton/skeleton.mk
index 7a7c200f7..d580fcbff 100644
--- a/package/skeleton/skeleton.mk
+++ b/package/skeleton/skeleton.mk
@@ -17,6 +17,12 @@ ifeq ($(BR2_ROOTFS_SKELETON_CUSTOM),y)
SKELETON_PATH = $(call qstrip,$(BR2_ROOTFS_SKELETON_CUSTOM_PATH))
+ifeq ($(BR_BUILDING),y)
+ifeq ($(SKELETON_PATH),)
+$(error No path specified for the custom skeleton)
+endif
+endif
+
ifeq ($(BR2_ROOTFS_MERGED_USR),y)
# Ensure the user has prepared a merged /usr.