summaryrefslogtreecommitdiff
path: root/package/sl
diff options
context:
space:
mode:
authorJens Rosenboom <j.rosenboom@x-ion.de>2015-04-01 11:08:45 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-04-03 16:31:04 +0200
commit5c4aa31640d9e80b80373fe229e5f789c4645e27 (patch)
treec06af3528d574d894c5c7cb742209f0ac0037fb0 /package/sl
parentea6b7bd5455e733c9fb006c7ed3103459b62d0fe (diff)
sl: new package
SL (Steam Locomotive) runs across your terminal when you type "sl" as you meant to type "ls". It's just a joke command, and not useful at all. [Thomas: - Change "depends on BR2_PACKAGE_NCURSES" to "select BR2_PACKAGE_NCURSES". - Rewrap Config.in help text. - Remove comment in help text about the need to check dependencies, there's nothing to be done really. - Change the license from "Unclear" to "Custom". - Use $(TARGET_CONFIGURE_OPTS instead of passing CC and CFLAGS explicitly. - Pass '-m 0755' when doing the $(INSTALL) - Add ncurses to SL_DEPENDENCIES.] Signed-off-by: Jens Rosenboom <j.rosenboom@x-ion.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sl')
-rw-r--r--package/sl/Config.in9
-rw-r--r--package/sl/sl.mk21
2 files changed, 30 insertions, 0 deletions
diff --git a/package/sl/Config.in b/package/sl/Config.in
new file mode 100644
index 000000000..7abe70567
--- /dev/null
+++ b/package/sl/Config.in
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SL
+ bool "sl"
+ select BR2_PACKAGE_NCURSES
+ help
+ SL (Steam Locomotive) runs across your terminal when you
+ type "sl" as you meant to type "ls". It's just a joke
+ command, and not useful at all.
+
+ https://github.com/mtoyoda/sl
diff --git a/package/sl/sl.mk b/package/sl/sl.mk
new file mode 100644
index 000000000..bb28b2a49
--- /dev/null
+++ b/package/sl/sl.mk
@@ -0,0 +1,21 @@
+################################################################################
+#
+# sl
+#
+################################################################################
+
+SL_VERSION = 5.02
+SL_SITE = $(call github,mtoyoda,sl,$(SL_VERSION))
+SL_LICENSE = Custom
+SL_LICENSE_FILES = LICENSE
+SL_DEPENDENCIES = ncurses
+
+define SL_BUILD_CMDS
+ $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define SL_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/sl $(TARGET_DIR)/usr/bin/sl
+endef
+
+$(eval $(generic-package))