summaryrefslogtreecommitdiff
path: root/package/snmppp
diff options
context:
space:
mode:
authorLuca Ceresoli <luca@lucaceresoli.net>2014-04-07 00:20:04 +0200
committerPeter Korsgaard <peter@korsgaard.com>2014-04-08 01:19:15 +0200
commitac6718e73f89ce4f99e8a52a6de85ecbc09f2eef (patch)
treec3da954e654da5d1e30c2a377669cbb0385ceff9 /package/snmppp
parentcdf8dcd0cc4f74baee50b21f9c479ae27151ea6e (diff)
snmppp: add option to enable logging
SNMP++ logging can be overly verbose, and according to the SNMP++ documentation, disabling logging "increases performance drastically and minimizes memory consumption". Signed-off-by: Luca Ceresoli <luca@lucaceresoli.net> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/snmppp')
-rw-r--r--package/snmppp/Config.in11
-rw-r--r--package/snmppp/snmppp.mk1
2 files changed, 12 insertions, 0 deletions
diff --git a/package/snmppp/Config.in b/package/snmppp/Config.in
index 5d6d749b8..1d5113fbb 100644
--- a/package/snmppp/Config.in
+++ b/package/snmppp/Config.in
@@ -8,5 +8,16 @@ config BR2_PACKAGE_SNMPPP
http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html
+if BR2_PACKAGE_SNMPPP
+
+config BR2_PACKAGE_SNMPPP_LOGGING
+ bool "enable logging"
+ help
+ Enable logging output for SNMP++.
+ According to the SNMP++ documentation, disabling logging "increases
+ performance drastically and minimizes memory consumption".
+
+endif
+
comment "snmp++ needs a toolchain w/ threads, C++"
depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/snmppp/snmppp.mk b/package/snmppp/snmppp.mk
index 78d7dc92c..3f3018d2a 100644
--- a/package/snmppp/snmppp.mk
+++ b/package/snmppp/snmppp.mk
@@ -11,6 +11,7 @@ SNMPPP_DEPENDENCIES = openssl host-pkgconf
SNMPPP_INSTALL_STAGING = YES
# no configure script in tarball
SNMPPP_AUTORECONF = YES
+SNMPPP_CONF_OPT = $(if $(BR2_PACKAGE_SNMPPP_LOGGING),--enable-logging,--disable-logging)
SNMPPP_LICENSE = SNMP++
SNMPPP_LICENSE_FILES = src/v3.cpp