summaryrefslogtreecommitdiff
path: root/package/sox
diff options
context:
space:
mode:
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>2016-02-29 16:39:42 +0000
committerPeter Korsgaard <peter@korsgaard.com>2016-03-01 11:30:34 +0100
commit1834024ba00caa91b5e6c32e15b142bfdfb19d15 (patch)
treeea07d05c745bcfbff32e248a21e6004d286c37fc /package/sox
parent8b186e089df052f1d5d84c71ff5db97505e903fe (diff)
sox: disable SSP when using MIPS Codescape toolchains
MIPS Codescape toolchains don't support stack-smashing protection despite of using glibc, therefore we see failures like this one: mips-img-linux-gnu/bin/ld: cannot find -lssp Fixes: http://autobuild.buildroot.net/results/957/95721f7b88c46a20202fb02e408817097df965c3/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Diffstat (limited to 'package/sox')
-rw-r--r--package/sox/sox.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/sox/sox.mk b/package/sox/sox.mk
index f4d160876..61f522018 100644
--- a/package/sox/sox.mk
+++ b/package/sox/sox.mk
@@ -13,6 +13,12 @@ SOX_CONF_OPTS = --with-distro="Buildroot" --without-ffmpeg --disable-gomp \
SOX_LICENSE = GPLv2+ (sox binary), LGPLv2.1+ (libraries)
SOX_LICENSE_FILES = LICENSE.GPL LICENSE.LGPL
+# MIPS Codescape toolchains don't support stack-smashing protection
+# despite of using glibc.
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_IMG_MIPS)$(BR2_TOOLCHAIN_EXTERNAL_CODESCAPE_MTI_MIPS),y)
+SOX_CONF_OPTS += --disable-stack-protector
+endif
+
ifeq ($(BR2_PACKAGE_ALSA_LIB_PCM),y)
SOX_DEPENDENCIES += alsa-lib
else