summaryrefslogtreecommitdiff
path: root/package/spice
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin@gmail.com>2014-09-27 21:32:44 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-04 18:54:16 +0200
commitaaffd209fae91a733fe0becb72268f87bf4ea369 (patch)
tree40569895ef8a09c605060e2164d86567a12f9889 /package/spice
parent1d2574ac6f6d30044ee138b6235c50a6a3998d8a (diff)
packages: rename FOO_CONF_OPT into FOO_CONF_OPTS
To be consistent with the recent change of FOO_MAKE_OPT into FOO_MAKE_OPTS, make the same change for FOO_CONF_OPT. Sed command used: find * -type f | xargs sed -i 's#_CONF_OPT\>#&S#g' Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/spice')
-rw-r--r--package/spice/spice.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/spice/spice.mk b/package/spice/spice.mk
index c20d42da8..117d08c48 100644
--- a/package/spice/spice.mk
+++ b/package/spice/spice.mk
@@ -21,7 +21,7 @@ SPICE_DEPENDENCIES = \
# We disable everything for now, because the dependency tree can become
# quite deep if we try to enable some features, and I have not tested that.
-SPICE_CONF_OPT = \
+SPICE_CONF_OPTS = \
--disable-opengl \
--disable-smartcard \
--disable-automated-tests \
@@ -30,24 +30,24 @@ SPICE_CONF_OPT = \
SPICE_DEPENDENCIES += host-pkgconf
ifeq ($(BR2_PACKAGE_SPICE_CLIENT),y)
-SPICE_CONF_OPT += --enable-client
+SPICE_CONF_OPTS += --enable-client
SPICE_DEPENDENCIES += xlib_libXfixes xlib_libXrandr
else
-SPICE_CONF_OPT += --disable-client
+SPICE_CONF_OPTS += --disable-client
endif
ifeq ($(BR2_PACKAGE_SPICE_GUI),y)
-SPICE_CONF_OPT += --enable-gui
+SPICE_CONF_OPTS += --enable-gui
SPICE_DEPENDENCIES += cegui06
else
-SPICE_CONF_OPT += --disable-gui
+SPICE_CONF_OPTS += --disable-gui
endif
ifeq ($(BR2_PACKAGE_SPICE_TUNNEL),y)
-SPICE_CONF_OPT += --enable-tunnel
+SPICE_CONF_OPTS += --enable-tunnel
SPICE_DEPENDENCIES += slirp
else
-SPICE_CONF_OPT += --disable-tunnel
+SPICE_CONF_OPTS += --disable-tunnel
endif
SPICE_CONF_ENV = PYTHONPATH=$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages
@@ -75,6 +75,6 @@ SPICE_POST_INSTALL_STAGING_HOOKS += SPICE_POST_INSTALL_STAGING_FIX_PC
# Note that NOEXECSTACK on a kernel with address space randomization
# is generally sufficient to prevent most buffer overflow exploits
# without increasing code size.
-SPICE_CONF_OPT += gl_cv_warn__fstack_protector_all=no
+SPICE_CONF_OPTS += gl_cv_warn__fstack_protector_all=no
$(eval $(autotools-package))