summaryrefslogtreecommitdiff
path: root/package/sqlcipher
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2015-10-15 07:42:51 -0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2015-10-15 13:27:30 +0200
commit0d6937644cafe3ed537194724159c473736bc57a (patch)
tree11db8bd3e36cb25a6acde7a3ff314fe76d8ff109 /package/sqlcipher
parentfe277eac1f97050d3f9c7f9d3d1558ca4a1707d0 (diff)
sqlcipher: disable tcl support
In commit b1dcb1c2 a fix was attempted at fixing a build failure where sqlcipher finds the distribution tcl and tries to build against it. sqlcipher has two tcl usage scenarios: host-tcl which is required to actually build it, and target tcl to build bindings. Since cross-compilation of the bindings isn't clean it fails as well, and since it wasn't a feature before either just disable it completely, since the wrong fix makes the sqlcipher build failures worse. Fixes: http://autobuild.buildroot.net/results/fc0/fc0528de7fed2f34f503fe8dd8b4c21ded0d6dff/ Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sqlcipher')
-rw-r--r--package/sqlcipher/sqlcipher.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/sqlcipher/sqlcipher.mk b/package/sqlcipher/sqlcipher.mk
index fadec2207..196f16275 100644
--- a/package/sqlcipher/sqlcipher.mk
+++ b/package/sqlcipher/sqlcipher.mk
@@ -15,7 +15,7 @@ SQLCIPHER_CONF_ENV = \
SQLCIPHER_CONF_OPTS = \
--enable-threadsafe \
- --with-tcl=$(HOST_DIR)/usr/lib
+ --disable-tcl
SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
SQLCIPHER_CONF_ENV += LIBS="-lcrypto -lz"