summaryrefslogtreecommitdiff
path: root/package/sqlcipher
diff options
context:
space:
mode:
authorJörg Krause <jkrause@posteo.de>2014-10-18 00:36:33 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2014-10-18 19:27:42 +0200
commitffa33dc55247cdad1770389b891175e510b0857b (patch)
tree896c65e1daa67b47efd574f0d1977d28b685add5 /package/sqlcipher
parentb3ed7c2d6898e643dd399d926d0f94295b15a35c (diff)
package/.mk files: remove --localstatedir=/var from autotools packages
Remove --localstatedir=/var from all autotools packages where it is no longer needed. Also remove --localstatedir=/var/lib/dhcp from package dhcp. localstatedir is used by dhcp to set the default directory for the leases files. This can also be done by setting --with-*-lease-file=/var/lib/dhcp/*, which is done in dhcp.mk. A custom --localstatedir is left in: * proftpd.mk * mysql.mk This is safe to do: One of the good thing with autoconf is that if you pass: --localstatedir=/var ... --localstatedir=/var/something Then /var/something will be used. So, we can set --localstatedir=/var by default in the infrastructure, and still have certain packages doing weird things override it. [Thanks to Thomas Petazzoni] Signed-off-by: Jörg Krause <jkrause@posteo.de> Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sqlcipher')
-rw-r--r--package/sqlcipher/sqlcipher.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/sqlcipher/sqlcipher.mk b/package/sqlcipher/sqlcipher.mk
index 253e31110..a11871884 100644
--- a/package/sqlcipher/sqlcipher.mk
+++ b/package/sqlcipher/sqlcipher.mk
@@ -15,8 +15,7 @@ SQLCIPHER_CONF_ENV = \
TCLSH_CMD=$(HOST_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
SQLCIPHER_CONF_OPTS = \
- --enable-threadsafe \
- --localstatedir=/var
+ --enable-threadsafe
SQLCIPHER_CFLAGS += -DSQLITE_HAS_CODEC # Required according to the README
SQLCIPHER_LDFLAGS += -lcrypto -lz