summaryrefslogtreecommitdiff
path: root/package/sqlite
diff options
context:
space:
mode:
authorBernd Kuhls <bernd.kuhls@t-online.de>2016-02-08 20:56:41 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2016-02-23 23:56:02 +0100
commit007c2ce917199339c0876227c2e612b11f8e7e15 (patch)
treed4bccdddcfe55b4066fab7f1cce75f1f5e3dbcfa /package/sqlite
parent6c49ae49d9cf42d29b31505054b79ea414c33480 (diff)
package/sqlite: add optional support for libedit
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/sqlite')
-rw-r--r--package/sqlite/Config.in7
-rw-r--r--package/sqlite/sqlite.mk9
2 files changed, 6 insertions, 10 deletions
diff --git a/package/sqlite/Config.in b/package/sqlite/Config.in
index 7ea9eb15b..c9fde53b3 100644
--- a/package/sqlite/Config.in
+++ b/package/sqlite/Config.in
@@ -8,13 +8,6 @@ config BR2_PACKAGE_SQLITE
if BR2_PACKAGE_SQLITE
-config BR2_PACKAGE_SQLITE_READLINE
- bool "Command-line editing"
- select BR2_PACKAGE_NCURSES
- select BR2_PACKAGE_READLINE
- help
- Enable command-line editing. This requires ncurses and readline.
-
config BR2_PACKAGE_SQLITE_STAT3
bool "Additional query optimizations (stat3)"
help
diff --git a/package/sqlite/sqlite.mk b/package/sqlite/sqlite.mk
index 0a119cc30..870b891c4 100644
--- a/package/sqlite/sqlite.mk
+++ b/package/sqlite/sqlite.mk
@@ -45,11 +45,14 @@ else
SQLITE_CONF_OPTS += --disable-threadsafe
endif
-ifeq ($(BR2_PACKAGE_SQLITE_READLINE),y)
+ifeq ($(BR2_PACKAGE_NCURSES)$(BR2_PACKAGE_READLINE),yy)
SQLITE_DEPENDENCIES += ncurses readline
-SQLITE_CONF_OPTS += --enable-readline
+SQLITE_CONF_OPTS += --disable-editline --enable-readline
+else ifeq ($(BR2_PACKAGE_LIBEDIT),y)
+SQLITE_DEPENDENCIES += libedit
+SQLITE_CONF_OPTS += --enable-editline --disable-readline
else
-SQLITE_CONF_OPTS += --disable-readline
+SQLITE_CONF_OPTS += --disable-editline --disable-readline
endif
$(eval $(autotools-package))